The default bug view has changed. See this FAQ.

when browsing a localhost (Intranet, not Internet) file, links that use the file:// scheme are not followed!

RESOLVED DUPLICATE of bug 84128

Status

()

Core
Networking: File
RESOLVED DUPLICATE of bug 84128
14 years ago
14 years ago

People

(Reporter: ezra epstein, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Put something like this in an html file on your LOCAL (127.0.0.1) server:
   <html><head></head><body>
   <br><br>
   <a href="file:///c%3A">Browse Via OS</a>
   <br>
   <br><br>
   </body></html>
The file needs to be served from a local web server (not simply opened locally, 
e.g., via drag & drop).  The link should work but it doesn't.  Mozilla seems to 
not be checking if the source page is local (it is) and then allowing the 
file:// scheme to function, it seems instead to require the user to start off 
in the file:// scheme for such a link to work.  Note if you right-click and 
select "Copy Link Location" and paste that into the location: field the 
directory is shown.

Reproducible: Always

Steps to Reproduce:
1. Create the file like the one mentioned in Details, above.
2. Make sure the file is served by an httpd server.
3. Access the file LOCALLY.
4. The link doesn't function.  I think it should (does in IE).

Actual Results:  
No action occurs in the browser.

Expected Results:  
The linked-to local directory should open in browse mode just as if you entered 
(or copied) the location into the "Location:" field in the browser.

Comment 1

14 years ago
That is by design and can be toggled by a pref. See the Release Notes.
(same for 1.5)

http://www.mozilla.org/releases/mozilla1.6b/known-issues.html#psm

So the bug is invalid.
Summary: when browsing a localhost (Intranet, not Internet) file, links that use the file:// scheme are not followed! → when browsing a localhost (Intranet, not Internet) file, links that use the file:// scheme are not followed!

Comment 2

14 years ago
see also bug 84128

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.