Re-prompting for uninstalled plug-ins is annoying

RESOLVED DUPLICATE of bug 83754

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 83754
15 years ago
12 years ago

People

(Reporter: codegardener, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When browsing without a particular plug-in installed (in my case, Shockwave
Flash), the user is re-prompted about the missing plugin every time it is
needed.  It would be wonderful if the prompt dialog had a check box that said
"Do not prompt me about this plug-in again".  When using the "Open in Tabs" in a
folder full of bookmarks (a great feature that I use every day, BTW), I
sometimes wind up with a whole stack of prompts that have to be cleared
individually.

Adding this feature might generate some confusion.  If a user has previously
declined to install a plug-in and then encounters a page where they would like
the plug-in to work they may not be able to figure out what is wrong.  Whether
the user is confused or not, there needs to be another method of getting the
plug-in downloaded at this point.  One solution to this would be to display the
information about the missing plug-in in some less invasive way, either right
from the start or only after a user has once declined to install it.  For
example, a little button/link might be displayed on the broken page element that
would raise the dialog box when clicked.  Or, the broken element might be given
a tooltip so that mousing over it would raise an explanation.  Or, an
icon/message might be displayed in the status bar to indicate that the page
requires a missing-but-declined plug-in.  With any of these solutions, the
original dialog box where the user declined to install the plug-in could warn
the user of what they will see in the future for that type, so they are better
informed about what is going on.

Thanks for all the great work that has gone into  Firebird.


Reproducible: Always

Steps to Reproduce:
1. Use a browser without Shockwave Flash installed.
2. Go to: http://www.doonesbury.com/strip/dailydose/index.html, observe the prompt
3. Reload the page.  Observe the prompt again.

Comment 1

15 years ago
Dup of bug 83754 via bug 200613 (and many others).

*** This bug has been marked as a duplicate of 83754 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Re-prompting for uninstalled plu-ins is annoying → Re-prompting for uninstalled plug-ins is annoying
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.