Mail composition Save --> Draft/Template loses message with IMAP

RESOLVED DUPLICATE of bug 243184

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED DUPLICATE of bug 243184
15 years ago
10 years ago

People

(Reporter: Jorey Bump, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({dataloss})

Trunk
x86
Windows 98
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208

When composing a message for an IMAP account, clicking on the Save icon works,
saving the message to the specified Drafts folder. However, using the Save
dropdown menu and choosing Draft or Template displays the transfer box, as if it
is saving the message, but no copy is saved in any folder on any account or in
any local folder. The feature works as expected with POP accounts, saving the
draft to that account's local folder.

I have only tested this against various versions of the UW-IMAP server, and it
fails every time. And, yes, I learned the hard way, with a very important
message, so please mark this as critical, because it results in lost mail
without any indication to the user.
 

Reproducible: Always

Steps to Reproduce:
1. Open compose window from IMAP account with remote Drafts folder.
2. Use Save --> Draft from Save icon's dropdown menu.
3. Where's the message?

Actual Results:  
Message does not appear in Drafts folder of IMAP account (or anywhere else, for
that matter).

Expected Results:  
Saved the draft to the Drafts folder.

I discovered this in v1.5, and confirmed it to still exist in v1.6b.
(Reporter)

Comment 1

15 years ago
Very strange... After checking to see if File --> Save As --> Draft works from
the main menu (it did), the problem disappeared. I thoroughly tested this...
maybe there's a problem the first time you use the Save dropdown? Go figure.  

Updated

15 years ago
Keywords: dataloss
This works fine in POP3, meaning it's most likely an IMAP issue, changing:

Component->Networking:IMAP

As this isn't about the composition of the email (which apparantly works), but
what happens after you compose it, and decide to save it as a draft.
Component: Composition → Networking: IMAP

Comment 3

15 years ago
I was also able to reproduce this a couple of times on Mozilla 1.6/Win2K,
against Oracle Collaboration Suite (OCS) IMAP server. However, unlike in the
original bug description, it is not regularly reproducible, nor reproducible at
will. I've seen it happen twice so far, out of maybe 40 or 50 tries. I have not
been able to determine whether it has anything to do with the message content --
OCS has been known to generate non-IMAP-compliant Message IDs, at least in older
versions.

Comment 4

14 years ago
Same problem here with IMAP! Any workarounds?

I've been having a problem with the ver 1.6 final mail client under Windows 
XP. When I am composing a message and click the Save button to put it in the 
Drafts folder, it often doesn't get saved at all. I close the message and it's 
gone, permanently. Most of the time, I have to click the Save button twice in 
a row to get it to really save the message. (No error messages or anything 
when it doesn't save...) 

All my preferences for mail folder locations appear to be set correctly. 

This has been happening with two email accounts, both using MDaemon IMAP 
servers.

At this time I can reproduce this issue only if the draft folder is empty. If 
one or more messages stored in draft folder, "save" seems to be work correct.
Product: MailNews → Core

Comment 5

14 years ago
I have the same problem.  The first time I tried to reply to a message and save
as draft, it fails.  I quit and restarted, tried again.  This time, it saved the
message to the drafts folder (in fact it saved multiple times, once each time I
used the save icon), BUT the drafts folder still appears as EMPTY.  Checking the
actual IMAP file on the server shows that the same message is saved multiple
times, but the client seems to refuse to display it.  Quitting & restarting the
client fixed the problem - all multiple saved messages appear in the Drafts folder.
This may be an IMAP server problem.  I am running SUSE Linux 8.2 and
imap-2001a-38 (RPM qurey).
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 7

13 years ago
This bug continues to be always reproducible in Thunderbird version 1.0.6
(20050716).

No message is saved on the IMAP server. 

If the Drafts folder does not exist, it is created, but still no message.

Note that you *must* test this in the following manner:

1. Start Thunderbird.
2. Select an IMAP account.
3. Open a compose window and start writing a message.
4. Select Draft from the dropdown menu next to the Save icon.

Do *not* use the Save icon or File -> Save As from the menu. Once you do this in
a session, the dropdown menu next to the Save icon begins to work as expected.

 

Comment 8

12 years ago
I can confirm this with
Thunderbird 1.5.0.9 (Windows/20061207) (Windows XP-Pro)

Some precisions :
- it's reproductible on EMPTY imap drafts and templates imap folders
- it's reproductible only the first time you hit the save button or use file > save as... (if you hit it twice, messages are shown)

Steps :
1. Empty your draft and restart Th
2. look at you Drafts folder
ls -l | grep Drafts
-rw-------   1 xxx  xxx     2048 Feb  1 08:32 Drafts
3. Compose new message and hit Save. you can see briefly a progress bar that seems not to complete but Draft folder seems to be empty.
4. look again Drafts
-rw-------   1 xxx  xxx     2048 Feb  1 08:32 Drafts
5. Hit again Save : this time the progress bar completes and
-rw-------   1 xxx  xxx     2666 Feb  1 08:37 Drafts
6. from this point the Save works as expected (until you restart Th with an empty Draft/Template folder)

Comment 9

11 years ago
Similar problem with Thunderbird 1.5.0.10 (20070307) for Ubuntu Linux x86. The draft failed to appear in my IMAP Drafts folder every time I used File > Save As > Draft until I just used File > Save instead. After that Save As > Draft started working.

I noticed if I tried to save the same message twice it appeared then immediately disappeared. Maybe the problem is caused because Thunderbird thinks the message is already there and deletes what it thinks is the second copy but is really the only copy?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243184
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.