Cannot save media (image,...) from page info (validateFileName is not defined)

RESOLVED FIXED

Status

SeaMonkey
Page Info
RESOLVED FIXED
15 years ago
2 years ago

People

(Reporter: Gilles Durys, Assigned: Gilles Durys)

Tracking

Bug Flags:
blocking1.6 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
Since bug 223549, validateFileName has been moved out of contentAreaUtils.js to
utilityOverlay.js.
This cause the save media feature to fail.
(Assignee)

Comment 1

15 years ago
Created attachment 137271 [details] [diff] [review]
one-line patch to include utilityOverlay.js
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

15 years ago
Assignee: db48x → mozbug
Status: ASSIGNED → NEW
(Assignee)

Comment 2

15 years ago
Comment on attachment 137271 [details] [diff] [review]
one-line patch to include utilityOverlay.js

A simple patch like that could be in 1.6
Attachment #137271 - Flags: superreview?
Attachment #137271 - Flags: review?
Attachment #137271 - Flags: approval1.6?
(Assignee)

Updated

15 years ago
Flags: blocking1.6?
nice of them to do that for us :P

I'll just need to double check to see if page info still needs contentAreaUtils.js

Comment 4

15 years ago
not being able to save from the page info dialog isn't going to block 1.6 but
we'd certainly consider a reviewed patch for approval to land in 1.6. Time is
short so if this is gonna make it we'll need reviews to happen quickly.
Flags: blocking1.6? → blocking1.6-

Comment 5

15 years ago
Comment on attachment 137271 [details] [diff] [review]
one-line patch to include utilityOverlay.js

please request approval *after* you've secured the necessary reviews
Attachment #137271 - Flags: approval1.6?

Updated

15 years ago
Summary: Cannot save media → Cannot save media (image,...) from page info

Comment 6

15 years ago
Please have a look at what bug 225740 is trying to do, maybe this bug is fixed
there (I didn't look at it).
Summary: Cannot save media (image,...) from page info → Cannot save media (image,...) from page info (validateFileName is not defined)

Comment 7

15 years ago
Gilles: Asa set review flags, but without requesting review from a particular
person you will never get one.
(Assignee)

Comment 8

15 years ago
*** Bug 231470 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
Comment on attachment 137271 [details] [diff] [review]
one-line patch to include utilityOverlay.js

Asking David Brooks since he does most of the work in Page Info now.
Also requesting 'rs= '
Attachment #137271 - Flags: superreview?(bryner)
Attachment #137271 - Flags: superreview?
Attachment #137271 - Flags: review?(db48x)
Attachment #137271 - Flags: review?

Comment 10

15 years ago
Re comment #3: contentAreaUtils.js is still needed, e.g. because of function
saveURL.
Comment on attachment 137271 [details] [diff] [review]
one-line patch to include utilityOverlay.js

looks good, r=db48x

See also bug 225740, when that goes in this will have to include utility.js
instead
Attachment #137271 - Flags: review?(db48x) → review+
Attachment #137271 - Flags: superreview?(bryner) → superreview+
checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040209

Verified WFM - thanks!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.