The nested layer based layers don't load well, and cannot be conrolled by Javascript

VERIFIED DUPLICATE of bug 102695

Status

()

defect
VERIFIED DUPLICATE of bug 102695
16 years ago
16 years ago

People

(Reporter: hoze, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

In the page: http://hoze.fpn.hu/frameset/top_frame_test.htm
There are ~20-30 layers nested into each other, and there visibility is
controlled by javascript, it does work well under MS Internet Explorer, but not
for MOzilla, it doesn't seem to be loading te full page; neither the links, nor
the Javascipt (onClick event for controlling visibility) don't work.

Reproducible: Always

Steps to Reproduce:
1.Try to click on any text appering in the circle of the menu
2.
3.

Actual Results:  
Nothing happened :) It cannot set the (in)visibility, or load the links' targets.

Expected Results:  
It should set the current menu invisible and set visible a new set of layers. Or
load the link targets.
The problem here seems to be that the page contains several large, transparent
DIVs, one for each sub-menu, absolutly positioned on top of each other.  Each
DIV contains one sub-DIV for each option in its menu.  The menu-option DIVs are
hidden when they're not supposed to be active, but the large DIVs are always
visible (but transparent).  So, mouse events always go to the sub-menu with the
largest z-index property, which happens to be one of the sub-menus.  Its items
aren't visible at the start, so there's nothing to receive the events.  If the
main menu had the largest z-index, it would work, but none of the sub-menus would.

Anyway, Tech Evangelism?  The site needs be changed to hide the submenus
themselves instead of just their options.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.