Case sensitivity in file extension causing mime type resolution to fail

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: gcomeaux, Assigned: jdunn)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6a) Gecko/20031208
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6a) Gecko/20031208

When I receive webmail attachments with uppercase JPG extensions, here is the
message I receive from
Mozilla 1.6a:
'The file "Moose.JPG" is of type application/octet-stream (JPEG Image), and
Mozilla does not know how
to handle  this file type......"

Here is what the link looks like:
<a target="_blank"
href="/wam/MsgAttachment?msgid=3456&attachno=2&folder=INBOX&x=-123456789">Moose.JPG</a>

It seems as if this is not proper behavior considering
1) Mozilla determines the incoming data is JPEG
2) All other jpg images (with lower case extensions) are displayed properly.

Reproducible: Always

Steps to Reproduce:
1. Log on to a webmail service that does not store file path information in href
links of attachments
2. Attempt to open a JPEG image attachment with an uppercase extension ".JPG"


Actual Results:  
The "Opening <filename>" dialog appears asking how to open this file.

Expected Results:  
It should display the jpeg image as it does all other jpeg images.

My operating system is Trusted Solaris 8 7/03 ( a very troublesome environment ).
invalid. mozilla does not usually guess the type of data. most likely the server
sent Content-Type: application/octet-stream, which mozilla trusts.

if an http log (http://www.mozilla.org/projects/netlib/http/http-debugging.html)
shows that the server is actually not sending application/octet-stream as the
content-type, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

15 years ago
OS: other → Solaris
You need to log in before you can comment on or make changes to this bug.