Does not print to printer or file

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: mika.poikonen, Unassigned)

Tracking

Trunk
HP
HP-UX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.5) Gecko/20031027
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.5) Gecko/20031027

Tried to print from several sources, but none of them prints anything to printer
or to file. It does not even give the dialog, which tells print job. In Netscape
7 printing works fine, and Mozilla 1.4.00.01 (PA-RISC) doesn't remember.

I have not built this by myself. I have a copy from binary download. I've tried
to compile this, but got some strange errors.

Reproducible: Always

Steps to Reproduce:
1. Choose print
2. printer/file
3. print-button

Actual Results:  
nothing happends

Expected Results:  
printing dialog should appear, that tells printing job.

Theme, I'm using is Sky Pilot Classic, but it doesn't matter.

Comment 1

15 years ago
Mika, could you launch mozilla from a command line, try to print, and see if
mozilla produces any error messages?

Comment 2

15 years ago
Mika, are you still experiencing this problem? Could you respond to the previous
question?

Comment 3

15 years ago
Mika responded to me in email (on, ahem, january 4th):

Sorry Kenneth. I replied directly to bugzilla-daemon.. =)

Yes. I'm still experiencing this problem.

/tmp.
---------------------------

It does not give any output. Not as a regular user or as the 
root user. =(

Comment 4

15 years ago
*** Bug 232800 has been marked as a duplicate of this bug. ***
What are the configure options used for your build (see "about:buildconfig")
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

15 years ago
(In reply to comment #5)
> What are the configure options used for your build (see "about:buildconfig")

Here's the config-information from Mozilla 1.6b:

Build platform
target
hppa2.0w-hp-hpux11.00

Build tools
Compiler 			Version Compiler flags
cc -Ae +DAportable +DS2.0 	N/A 	-DHPUX11
aCC -ext +DAportable +DS2.0 	N/A 	-DHPUX11 -Dhpux +W358,652,728,740,749,829

Configure arguments
--disable-debug --disable-tests --enable-crypto --enable-extensions=default
'--enable-optimize=+O3 +Onolimit +Osize' --enable-mathml --disable-auto-deps


1.5 I've got not now, but I can re-install it, if wanted.

/tmp.

Comment 7

15 years ago
I'm not sure if this is a duplicate problem or a separate bug: I have 1.6
installed from RPM on Mandrake 9.2. When I print from Mozilla using lpr, xpp, or
kprinter, the data light on the printer blinks once as if data were being sent,
but nothing is printed. If I print to a file, I get a ~300k .ps file that shows
up as blank in KGhostView and will not convert to PDF with ps2pdf. The print
preview looks normal. I tried running mozilla from the command line, and no
error appears during printing.

Comment 8

14 years ago
Mika, is this still a problem with current versions of mozilla (or firefox or
thunderbird)? Where are you getting your copy of mozilla? Is it supplied by HP?
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> Mika, is this still a problem with current versions of mozilla (or firefox or
> thunderbird)? Where are you getting your copy of mozilla? Is it supplied by HP?

I'm sorry about delayed answer time. =) Well.. Because I need to print every now
and then from web, I had to go on with NS. I downloaded sources for 1.7.8 couple
of days ago, but not luck with compiling to see, if problem still exist.

You may, if you want to, mark this as unsolved/discontinued.

/tmp.
(Reporter)

Comment 10

13 years ago
Ok. Now installed Mozilla 1.7 (Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US;
rv:1.7) Gecko/20040714) binaries from mozilla.org and tried printing... =)

As you can see happy smile, I will continue at least with this version.
I sure will give a try to later versions too.

I'll mark this to fixed ( if I can), because printing works fine at least in
this version (1.7)

/tmp.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Reopen to resolve WFM, fixed is only for when code changes that caused the fix
are known.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
WFM as per comment 10
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.