freezes if i hold alt and scroll mouse wheel

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Shannon, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

alt + mouse wheel should change size of text, instead it freezes Firebird and
windowmaker. i used "things they left out" extension to change alt + mouse wheel
to scroll through history, but it still crashes

Reproducible: Always

Steps to Reproduce:
1. install things they left out extension
2. hold alt and scroll mouse wheel
3. sometimes holding ctrl and scrolling wheel unfreezes program

Actual Results:  
browser freezes

Expected Results:  
change size of text (or go through history, depending on TTLO settings)
WFM on gtk2+xft Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031206
Firebird/0.7+

Comment 2

14 years ago
WFM too.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031218 Firebird/0.7+

Comment 3

14 years ago
I think this is not a bug of neither Mozilla nor Firebird
since alt (Mod1) + mousewheel (in fact Button4/5 click) is mapped for grabbing
window in the WindowMaker.

There is no doubt if you could reproduce the same situation in other applications.

Solutions:
1. Change wmaker's setting
RIght-click the titlebar of Mozilla or press Ctrl+ESC.
[Attributes...]->[Advanced Options]->[Do not bind mouse click]

2. If you don't like the above setting which also disables alt+Button1/2 for
grabbing window and alt+Button3 for resizing window,
I'll post a patch for wmaker later.

Comment 4

14 years ago
>alt + mouse wheel should change size of text, instead it freezes Firebird

I'm pretty sure Ctrl+Mouse Wheel is used to change text size,
according to Firefox Help Alt+Mouse Wheel is for scrolling line by line.

WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040324 Firefox/0.8.0+
running KDE from Knoppix CD.

Comment 5

14 years ago
Worksforme with 20040429 Firefox linux build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.