ctrl-enter on address toolbar should remove trailing blankspace

VERIFIED DUPLICATE of bug 233205

Status

()

Firefox
Toolbars and Customization
VERIFIED DUPLICATE of bug 233205
14 years ago
11 years ago

People

(Reporter: Tarun Upadhyay, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Steps to replicate:
a)type "foo " in web address bar.
b)Press ctrl-enter

Current Result:
Firebird displays an alter box with message: 
   "The URL is not not valid and cannot be loaded."
It is preferable if it just truncates the trailing white space and tries the URL
then.

The problem is more acute on windows because many applications on windows will
cut text (specially if one double clicks on the word with mouse) with the
trailing blank in it and if that is pasted in firebird, the result will not form
a valid URL.

Reproducible: Always

Steps to Reproduce:
1. Write "beganto" in a MS-word file
2. double click on the word "beganto" such that windows selects that word (With
trailing blank space)
3. right click  and copy the selected word.
4. right click and paste it in the address toolbar on firebird
5. Press Ctrl-enter

Actual Results:  
Firebird displays an alter box with message: 
   "The URL is not not valid and cannot be loaded."

Expected Results:  
truncated the trailing blank space and tried to fetch "www.beganto.com"

Comment 1

14 years ago
this is a bug
it works with mozilla 1.6b, it doesn't work with firebird 0.7+ 20031214 windows
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
WFM as of 20050610.

*** This bug has been marked as a duplicate of 233205 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.