Closed Bug 228781 Opened 16 years ago Closed 16 years ago

Table gets distorted if nested in two or more divs with "position:absolute"

Categories

(Core :: Layout: Tables, defect)

Other
Other
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 201897

People

(Reporter: marcus, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.5) Gecko/20031017
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.5) Gecko/20031017

Mozilla does not render the table cell widths correctly, if the table is located
in two or more nested divs with style="position:absolute" (See URL obove). If I
change one or both divs to "position:relative", everything works fine.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.mvcsys.de/test/mozilla-bug.html
2. view the results


Actual Results:  
Table cells do not align properly

Expected Results:  
Table cells should align properly

Bug seems to be older (in all 1.x versions)
a dupe of bug 97777 ?
Doesn't seem to be a dupe of bug 97777, since this affects the behaviour of the
divs, not of the contained table. In our case the table cell widths aren't
calculated properly so that the cells are no longer properly aligned: the rows
seem to be independent from each other.
I just added two screenshots and a third case to the example page (IE6 and
Mozilla 1.5 under Windows). (I had to add another level of DIVs to seperate the
examples!)

A soon as I add a width to the outer of the positioned DIVs, everything seems to
work as expected! The problem seems to have to do with computing the width of
the outermost surrounding div. (Just a guess).

*** This bug has been marked as a duplicate of 201897 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Bug is still present in Mozilla 1.6 (see URL above)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
So?

*** This bug has been marked as a duplicate of 201897 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.