If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

the combination border-style double and thin width does not work

VERIFIED DUPLICATE of bug 1781

Status

()

Core
CSS Parsing and Computation
P3
minor
VERIFIED DUPLICATE of bug 1781
18 years ago
16 years ago

People

(Reporter: Thomas Jespersen, Assigned: Pierre Saslawsky)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
If you look at the above URL, the paragraph should have a double, think border
set with this stylesheet:

border-style: double;
border-width: thin;

the border does not appear with the latest "nightly" build on a linux system. It
does however seem to work with Netscape 4.7. If I try other values for
border-width, the border will appear correctly as a double style. If I try other
styles with thin width, everything will be ok. It seems to be just this combination.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 1

18 years ago
According to the spec, the sum of the two lines and the space between them must
equal the value of 'border-width'. Since you set the border width to 'thin' which
is 1 pixel, we get 1/3rd of a pixel for each line and the space between so
nothing gets displayed. When using a 'double' border, you should set the width to
a minimum of 3px or 'medium'.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
Verified invalid
Reopening to mark duplicate.  We should be handling this case better.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 1781 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → DUPLICATE
VERIFIED DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.