Closed Bug 228895 Opened 19 years ago Closed 19 years ago

"align" and "valign" attributes -- and their CSS equivalents -- are ignored at the <col> or <colgroup> level in tables. attributes must then be set at the individual <tr> or <td> level

Categories

(Core :: Layout: Tables, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 915

People

(Reporter: olaf, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007

Below is a test table to demonstrate the problem... Col 1 should display with
alignment Top-Right, as per HTML Spec.  In any Mozilla browser that I've tested,
the column ignores the <col> attributes and does not align correctly.

Note that the same problem occurs using the CSS Style method for <col> or
<colgroup> elements (i.e. the style is ignored).  Internet Explorer correctly
renders the pages, as per HTML spec.

<table border="1">

 <colgroup colspan="3" width="200">
  <col align="right" valign="top">
  <col>
  <col>
 </colgroup>

  <tr>
    <th>Test Header Col 1</th>
    <th>Test Header Col 2<br>Test</th>
    <th>Test Header Col 3</th>
  </tr>

  <tr>
    <td>Test Data Col 1</td>
    <td>Test Data Col 2</td>
    <td>Test Data Col 3<br>test</td>
  </tr>

</table>

Reproducible: Always

Steps to Reproduce:
1.  Set up a test HTML file, including the sample table included in "Details" 
2.  Open the HTML file in Mozilla.
3.  Gaze in wonder at the incorrectly aligned table-column

Actual Results:  
Table-column not aligned as expected.

Expected Results:  
Correctly rendered the table-column alignment.
This is a dupe of an old bug, bug 915.
Component: Browser-General → Layout: Tables
Paul, if you want to submit a reduced testcase (which is ok and appreciated),
then use the "Create a New Attachment" in the form. Also, check if the bug has
no duplicate and keep summary to its most relevant description.

I'm marking this as a DUPLICATE of bug 915.

*** This bug has been marked as a duplicate of 915 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.