page does not redirect; if you manually type in redirect, it says you must use IE v5.0

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: ecarpenter, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6a) Gecko/20031025
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6a) Gecko/20031025

https://navinet.navimedix.com is the entry for insurance checking on line.  It
should redirect to https://navinet.navimedix.com/Main.asp  
Mozilla displays a blank page for the first one (though there is script when you
check "page source."  If you manually type in
https://navinet.navimedix.com/Main.asp it displays an error page saying navinet
requires IE version 5.0 or higher.  What should display is a log on page. 
Internet Explorer does display this correctly.  IE asks to use ActiveX controls
if you have it set to ask first, but will perform correctly even if you deny
permission.

Reproducible: Always

Steps to Reproduce:
1. go to https://navinet.navimedix.com
2. when nothing happens, go to https://navinet.navimedix.com/Main.asp
3.

Actual Results:  
1. blank page
2. error page

Expected Results:  
1. redirect to 2.
2. display page requesting ID and password.
Several things here.  First of all the main page that you should be directed to
clearly states:

-----------------------------------------------------------
Your browser is not supported by NaviNet.
NaviNet requires Microsoft® Internet Explorer v5.0 or higher.
-----------------------------------------------------------


As far as the redirect.  The page has an error in the javascript:

Error: handlePageOnLoad is not defined

I'm not to great with javascript (though trying to learn)... but the offending
code looks like:

-----------------------------------------------------------------
<SCRIPT language="jscript">function handlePageOnLoad()
{
preloadElement.addBehavior("NaviNetPreload1.htc");
document.createStyleSheet("rpa.css");
document.createStyleSheet("components/Toolbar/NMToolbar2.css");
}
function handlePreloadElementOnPreloadFinish()
{
window.navigate("Main.asp");
}
</SCRIPT>
--------------------------------------------------------------

which has most notably language set to jscript, when it should be "javascript".
 Perhaps someone with a bit more experience can point it more directly.  I
believe that will fix it, but I'm not positive, nor have I tested it.

This is an evangelism bug.
Severity: major → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
Product: Browser → Tech Evangelism
Version: Trunk → unspecified
Assignee: general → english-us
QA Contact: general → english-us

Comment 2

5 years ago
Seems fixed.
[closeme]
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.