-p command does not work when profile name contains international character(s)

RESOLVED DUPLICATE of bug 208363

Status

RESOLVED DUPLICATE of bug 208363
15 years ago
10 years ago

People

(Reporter: andr55, Assigned: law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; fr-FR; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; fr-FR; rv:1.4) Gecko/20030624

-p "profileName" works as documented online if profileName contains no
international characters.  (i.e. upper or lower-case P, quotes optional if no
space in profileName.)
If profileName contains an international character (e.g. é as in André) one is
asked to select a profile

Reproducible: Always

Steps to Reproduce:
1. Have 2 profiles defined, one without any international characters, the other
with at least one international character (such as "é").
2. In testing, test all variations of -P "profileName" -- i.e.: upper or
lower-case P, followed by a space, profileName matching case exactly of defined
profile, quotes optional if no space in profileName.
Test by adding parameters to a shortcut link to Mozilla.
Could alternately enter the command directly under "run".
3. Test profileName not containing any international characters.
4. Test profileName containing at least one international character.
Actual Results:  
If profileName contains no international characters, profile is automatically
selected.
If profileName contains any international characters, one is asked to select a
profile.

Expected Results:  
Automatically select the profile, even if profileName contains an international
character.

Behavior not tested with only one profile defined. (Not useful in that case.)
This option worked correctly under Mozilla 1.3.1 (before recent upgrade).
Each profileName tested matched exactly (in case and accents) the profileName
defined under the profile manager.
Bug rated as normal rather than minor because in some cases one wishes to hide
the profile selection from an occational user of one's computer (privacy/security).

Comment 1

15 years ago
==> cmd line

dupe of bug 208363?
Assignee: general → law
Component: Browser-General → XP Apps: Cmd-line Features
QA Contact: general → sairuh

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 208363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
This bug has been resolved under mozilla 1.6 (gecko/20040113)
(But bug 208363, to which it was assigned as duplicate is still classified as
unresolved!?)
(It does seem appropriate to have classified it as a UTF-8 error.)

Updated

10 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.