Cannot build Firebird 0.8 = breaking in nsAccessibilityService.cpp

RESOLVED FIXED

Status

()

--
blocker
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: fredbezies, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031220
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031220

All is in the title.

It breaks since this morning. I grabbed 3 times sources, and bug is present.

See steps below.

Reproducible: Always

Steps to Reproduce:
1.Grab a 0.8 firebird branch build
2.Update it
3.Launch build process.

Actual Results:  
Breaking in nsAccessibilityService.cpp

Expected Results:  
End building process.

Here is the log when building is killed :

[more than 13000 lines of good work after typing make -f client.mk build]

c:/logs/fire08/mozilla/accessible/src/base/nsAccessibilityService.cpp(466) :
error C2039: 'PresShell' : is not a member of 'nsDerivedSafe<class nsIPresContext>'
c:/logs/fire08/mozilla/accessible/src/base/nsAccessibilityService.cpp(533) :
error C2039: 'PresShell' : is not a member of 'nsDerivedSafe<class nsIPresContext>'
c:/logs/fire08/mozilla/accessible/src/base/nsAccessibilityService.cpp(651) :
error C2039: 'PresShell' : is not a member of 'nsDerivedSafe<class nsIPresContext>'
make[5]: *** [nsAccessibilityService.obj] Error 2
make[5]: Leaving directory `/cygdrive/c/logs/fire08/mozilla/accessible/src/base'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/cygdrive/c/logs/fire08/mozilla/accessible/src'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/cygdrive/c/logs/fire08/mozilla/accessible'
make[2]: *** [tier_9] Error 2
make[2]: Leaving directory `/cygdrive/c/logs/fire08/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/cygdrive/c/logs/fire08/mozilla'
make: *** [build] Error 2

It seems to be related to firebird trunk checkin for bug #227690.

How can this checkin gets in 0.8 branch ?
(Reporter)

Updated

15 years ago
Flags: blocking0.8?
(Reporter)

Comment 1

15 years ago
Reversing patch #2 from bug 227690 (attachment 137217 [details] [diff] [review]) doesn't seem to cure the
bug ?!
(Reporter)

Comment 2

15 years ago
Disregard previous comment. It seems I misapplied patch :[

So, reversing patch in previous comment kills the bug. Sorry for spamming :[
Sounds like Firebird is pulling accessibility but didn't bother to tag it...
(Reporter)

Comment 5

15 years ago
Mark it as FIXED, please. I release builds using the patch.

See http://forums.mozillazine.org/viewtopic.php?t=42189 (build was made using
23rd december source code).
Flags: blocking0.8?
-> ben
Assignee: bryner → bugs
Fixed on branch
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.