Closed Bug 229302 Opened 21 years ago Closed 21 years ago

Combo box starts flashing, and refuses to lose focus

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 232368

People

(Reporter: jhouse, Unassigned)

References

()

Details

(Keywords: hang, regression, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208

I think that all the other tidbits describe this bug pretty well (read steps to
reproduce and actual results sections).  I encountered this bug once, then
reproduced it, and then submitted this bug.  I have not played around with it a
lot since, forced closing of mozilla and restarting the browser is a
particularly nasty bug to deal with.

Reproducible: Always

Steps to Reproduce:
1. Go to www.creditexpert.com
2. Click on the "free" sign up link
3. Start entering information, tabing from field to field
4. (All the way until you reach the title combo box)

Actual Results:  
The combo box starts flashing.  Mozilla starts using 100% CPU load and becomes
non-responsive.

Expected Results:  
Combo box gets highlighted, I can optionally make a selection, and then
tab/click to the next field.
This is caused by a 

<select onfocus="blur()">

Tabbing into the select box seems to cause a endless loop and Mozilla hangs
completely after a few moments.
Assignee: general → events
Status: UNCONFIRMED → NEW
Component: Browser-General → Event Handling
Ever confirmed: true
Keywords: hang
QA Contact: general → ian
Attached file Minimized testcase
Forgot to mention: I tested this with build 2003122009 on Windows XP.
this regressed betwen linux trunk 2003110608 and 2003110708, along with 232368.
 testcase is very similar -- the testcase here has an onfocus handler that
triggers blur.

marking dupe of (newer bug) "Hang when tab into input element with onBlur handler"

*** This bug has been marked as a duplicate of 232368 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Keywords: regression, testcase
OS: Windows XP → All
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: