Internet Kewords: request hangs mozilla

VERIFIED DUPLICATE of bug 229668

Status

SeaMonkey
Location Bar
--
major
VERIFIED DUPLICATE of bug 229668
15 years ago
10 years ago

People

(Reporter: Isaac Hwak Han, Unassigned)

Tracking

({hang, regression})

Trunk
hang, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031224
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031224

This is a regression bug in current CVS trunk build.

Reproducible: Always

Steps to Reproduce:
1. Select Edit / Preference Menu
2. Go to Navigator / Smart Browsing Tab
3. Check "Enable Internet Keywords" to be on
4. Enter "mozilla" in the location bar
Actual Results:  
Mozilla hangs. Status bar saying "Resolving mozilla..."


"Internet Keywords" feature is default off in mozilla, but it's default on in
Firebird.

Comment 1

15 years ago
seeing this as well in Gecko/20031225 Firebird/0.7+. it stops responding on
entering any word into the adressbar and hitting return.
(Reporter)

Comment 2

15 years ago
It's weird the bug is still unconfirmed. Still see the problem in current trunk
build.

Interesting point is that when I enter a multi-word search term, it doesn't hang
and works, e.g.:

"mozilla": HANGS
"mozilla firedbird": WORKS
(Reporter)

Updated

15 years ago
Keywords: hang, regression
(Reporter)

Comment 3

15 years ago
It seems that the latest patch of bug 209699 caused this regression. I backed
out the patch for docshell/base/nsWebShell.cpp and it worked fine. Not sure what
should be done.

RCS file: /cvsroot/mozilla/docshell/base/nsWebShell.cpp,v

-          nsAutoString keywordSpec; keywordSpec.AssignWithConversion("keyword:");
-          keywordSpec.Append(NS_ConvertUTF8toUCS2(host));
-
-          NS_NewURI(getter_AddRefs(newURI), keywordSpec, nsnull);
+          NS_NewURI(getter_AddRefs(newURI),
+                    NS_LITERAL_CSTRING("keyword:") + host, nsnull);

Comment 4

15 years ago
-> NEW b/c of two reports.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: benc
Summary: Search by Internet Keywords hangs mozilla → Internet Kewords: request hangs mozilla

Comment 5

15 years ago
*** Bug 229581 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
This is a dup of bug 229668.

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 229668 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 8

15 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.