'onchange' event not firing for 'SELECT' element through keyboard

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 126379
14 years ago
14 years ago

People

(Reporter: Arun Nallan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

The test fails in firebird. I have tested it in Firebird 0.7 with Windows XP
platform. Not sure about other versions of Mozilla. Working correctly in IE
versions.

Reproducible: Always

Steps to Reproduce:
1. GO to url
http://www.w3.org/WAI/UA/TS/html401/cp0102/0102-ONCHANGE-SELECT.html or any
other URL which has an 'onchange' event handler for the SELECT element
2.Use keyboard to change the option in the select element
3.

Actual Results:  
Event not fired

Expected Results:  
Event should be handled. (for eg. javascript function like fn_onChange(); should
be called)
You have to hit enter or tab out of the select when you are done changing. 
Otherwise the onchange would fire every time you changed to a different option,
before you got to the one you actually wanted to select.  Given the number of
places that trigger navigation off onchange, that would be very poor.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.