StartPage: select file dialog incorrectly specifies url

VERIFIED WORKSFORME

Status

MailNews Core
Backend
P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: pmock, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
Build Date & Platform Bug Found:
 Win32 commercial seamonkey build 2000-01-03-09-m13 installed on P166 Win98
 macos commercial seamonkey build 2000-01-03-08-m13 installed on G3/400 OS 8.6

Overview Description:
 Under the "Messenger start page" section located in the mailnews category, if
you choose a local file on your hard disk, it will incorrectly specify the url.

For example, these are valid urls:
  file:/c:/junk/test.html
  /c:/junk/test.html

On Windows and Mac, it forgets the beginning "/" or "file:/".
I can work around the problem by typing in the missing character(s)

Steps to Reproduce:
1) Launch Seamonkey
   The browser page opens.
2) Select the Edit|Preference
3) Highlight the "mail and newsgroup" category
4) Under the Messenger start page section, click on the "select file" dialog
5) Choose a html file on your local drive
6) Press OK
   The dialog is dismissed and the url is displayed in the location field
    C:\1junk\test.html

Actual Results:
 The url/path is incomplete.  The start page will not load.  In some instances,
my folders do not list.

Expected Results:
 It should automatically put in the "file:/" text in the path. It should behaves
like 4.7 which does put "file:/" text.

Additional Builds and Platforms Tested On:
 This problem occurs on mac and win32 2000-01-02-09-m13 commercial seamonkey
build.

Additional Information:
 On Linux, I could not test because of bug 22780, but it should have the same
problem.
http://bugzilla.mozilla.org/show_bug.cgi?id=22780
(Reporter)

Updated

18 years ago
QA Contact: lchiang → pmock
Assignee: sspitzer → dougt
re-assign to dougt.  Mr. nsIFile.

Updated

18 years ago
Target Milestone: M14

Comment 2

18 years ago
dependant on nsIFile.

Comment 3

18 years ago
adding beta1 keyword and setting m14 checkpoint.
Status: NEW → ASSIGNED
Keywords: beta1

Comment 4

18 years ago
Putting on PDT- radar for beta1.  Would not hold beta for this.
Whiteboard: [PDT-]

Comment 5

18 years ago
see comments in 22961. 

If this turns out to be a url parsing problem after you apply the suggestion in 
22961, than the bug is nsFileSpec related.
Assignee: dougt → ben
Status: ASSIGNED → NEW
does this still happen? I checked in a change last night that always shows the 
file URL to prevent the mac from barfing. 

otherwise, M15
Target Milestone: M14 → M15
worksforme in 02/22/00
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
Linux (2000-03-10-13 M15)
Win32 (2000-03-10-09 M15)
Mac (2000-03-09-13 M15)
This bug is fixed on Mac and Win32.
However, on Linux:
6) Press OK
   The dialog is dismissed and the url is displayed in the location field
    file:///home/gor/interview.html
Actual Results:
 The url/path is complete but the start page will not load. 
Expected result: It should load like Mac and Win32.
Reopen the bug. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

18 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16
worksforme, linux 041000
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

18 years ago
Verified as fixed on win32, macos, and linux using the following builds:
 win32 commercial seamonkey build 00042809-m16 installed on Dell P500, Win98
 macos commercial seamonkey build 00042808-m16 installed on G3/400, MacOS 9.04
 linux commercial seamonkey build 00042809-m16 installed on P200, RedHat 6.1
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.