The default bug view has changed. See this FAQ.

Offline: UI elements do not set "network online" if "offline.startup_state" is selected on launch

RESOLVED WONTFIX

Status

()

Core
Networking
RESOLVED WONTFIX
13 years ago
2 years ago

People

(Reporter: benc, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
STEPS:

Via prefs, set "offline.startup_state" to 1
(Prefs | Mail & News | Offline | "When starting up: Ask me for online status at
startup")

Quit and resart.

Note startup selection. Select either mode button.

use about:config (filter for "online")

Click on any of the offline UI elements (like the button on the lower right).
Note that the pref does not change values interactively.
(Reporter)

Comment 1

13 years ago
I think I understand this better now.

Necko keeps the offline-online state internally. Only when
"offline.startup_state" = 0 (remember) should this value be maintained.

The problem is that if we start w/ "prompt me" mode, if you change
"offline.startup_state" to 0, the behavior doesn't change, network.online is not
updated.

Updated

11 years ago
Assignee: darin → nobody
QA Contact: benc → networking
"offline.startup_state" does not exist anymore
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.