BODY style "overflow:hidden" applies to DIVs with style "position:absolute"

RESOLVED DUPLICATE of bug 225811

Status

()

Core
Layout: View Rendering
--
major
RESOLVED DUPLICATE of bug 225811
15 years ago
15 years ago

People

(Reporter: Joerg Rossdeutscher, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20040103 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20040103 Firebird/0.7+

If you set "overflow:hidden" in the BODY style (i.e. to avoid scrollbars from
invisible DIVs, necessary for a lot of browsers) the "bounding box" around the
body applies to DIVs that are positioned "absolute".

That means: If you build a page that only contains DIVs, they are all invisible.

Here's some example. The DIV is cut of in the middle.

<html>
<body bgcolor="#cccccc" style="margin:0px; padding:0px; overflow:hidden;">
	<div id="blocked" style="position:absolute; top:100; left:100; width:400;
height:400;">
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
		div div div<br>
	</div>
	<br><br><br><br><br><br><br><br><br><br><br><br>The body ends here
</body>


</html>


Reproducible: Always

Steps to Reproduce:
1. Create a BODY "overflow:hidden;"
2. Create an "position:absolute;" DIV anywhere on page
3. View. Then put some more content in the body. GOTO 3.

Actual Results:  
Absolute DIVs are invisible. They re-appear when putting content into BODY.

Expected Results:  
BODY bounding-box does not apply to absolute DIVs. Has been until one version
ago, works that way on /every/ other browsers. Behaviour makes absolute DIVs
unusable.

Going through previous bugreports it seems thare have been made some changes to
the "overflow" behaviour previously Firebird 0.7. This might have caused the
problem. It was tested and occured on Linux and Macintosh, Firebird and Mozilla.

The "overflow:hidden;" style for the body may look a bit irritating. It is
neccessary, because some browsers show scrollbars for hidden DIVs.
Fixed in current builds.

*** This bug has been marked as a duplicate of 225811 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.