Inconsistent page on Back/Forwards

RESOLVED DUPLICATE of bug 38486

Status

()

RESOLVED DUPLICATE of bug 38486
15 years ago
10 years ago

People

(Reporter: jsfbbz, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When a page is modified via Javascript, then you navigate Back, then Forwards to
return to the page, input elements will have the values as last seen, but other
elements will be returned to their default page-load state.

Reproducible: Always

Steps to Reproduce:
1. Go to some random web page to prime history
2. See attachment.
3. Check, Do, Check, Back, Forwards, Check


Actual Results:  
"Old/Old/Old"
"New/New/New"
"Old/Old/New"

Expected Results:  
"Old/Old/Old"
"New/New/New"
"New/New/New"

I wouldn't have been too suprised by "Old/Old/Old" for the final state, but
would prefer "New/New/New". In my mind navigation should return you to an exact
copy of the DOM the last time you were at that page in the history.

(The original page, btw, is to edit a database object with several simple
attributes, which are edited in normal form fields, plus a link to another
database object which can't really be simply typed in. The JS pulls up another
form to find a new object to link to and sets the link text to an object
description, link href to info about the target object, and hidden field to the
database key for the new object. Accidental navigation then produces confusing
results since we do actually have the new target key, but the user *sees* the
old values and thinks the change has been discarded.)
(Reporter)

Comment 1

15 years ago
Created attachment 138345 [details]
Test case

Comment 2

15 years ago
Not Firebird-specific.
Component: History → History: Session
Product: Firebird → Browser
Version: unspecified → Trunk

Comment 3

15 years ago
I see this also.  Dupe of Bug 38486 via bug 189824.

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 38486 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: mozilla → docshell
You need to log in before you can comment on or make changes to this bug.