The default bug view has changed. See this FAQ.

bugzilla-submit 'Operating-System' and 'URL' fields are rejected

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Bugzilla-General
--
minor
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Joseph Heenan, Assigned: Christian Reis)

Tracking

(Blocks: 1 bug)

unspecified
Bugzilla 2.18
x86
Windows XP
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

The bugzilla-submit documentation and scripts refers to the field 'Operating-
System' field in several places, but trying to use the following input file:

Product: test
Version: dev-trunk
Component: Misc
Short-Desc: XXX test bug
Hardware: x86
Operating-System: Linux
URL: XXX URL
Severity: critical
Keywords: test

XXX test comment


gives the error:

bugzilla-submit: invalid field: Operating-System


Changing 'Operating-System' in the input file to just 'OS' appears to yield 
correct results. The URL line is also rejected in a similar manner.

This is against a local bugzilla installation running the current HEAD.

Patch coming.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 138359 [details] [diff] [review]
Patch to correct problem with field_aliases

This patch fixes both problems.

The operating-system problem appears to be a typo, the behaviour now matches
the other code and the documentation.

The URL problem is because header_to_field does a 'lower()' call on the
incoming header before checking it for an alias, so all the aliases must be
written in lower case.

Updated

13 years ago
Attachment #138359 - Flags: review?(kiko)
(Assignee)

Comment 2

13 years ago
Well:

a) do we want Operating-System or OS? I find the latter shorter and more to the
point, so it could be a matter of fixing the docs. I'm open for argument to the
contrary, though.

b) The comment you added is a bit confusing, since the set of tuples under it
has underscores :-) Should it be cleared up a bit?

Eric, any comments?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

13 years ago
Yeah, the comment is blatently wrong :-) Sorry guys.

I went for operating-system (rather than OS) because operating-system is used 
in one other place in the code as well as the docs.

But the command line long code for setting operating system is --os - I think 
I'm inclined to agree with you and will change it to use OS (and update the 
docs) unless anyone disagrees.

I'll produce an updated patch later on.
(Assignee)

Comment 4

13 years ago
Created attachment 139021 [details] [diff] [review]
kiko_v1: fix issues, add to testcase
Attachment #138359 - Attachment is obsolete: true
(Assignee)

Comment 5

13 years ago
Note that this is code in contrib.
Assignee: justdave → kiko
Flags: approval?
(Assignee)

Updated

13 years ago
Blocks: 230885
(Reporter)

Comment 6

13 years ago
You beat me to it kiko, thanks.

The changes look good to me.
(Assignee)

Updated

13 years ago
Attachment #138359 - Flags: review?(kiko)
Not sure contrib/ changes need approval (although contrib/ additions certainly
would), but here it is anyway; a=myk.
Flags: approval? → approval+
(Assignee)

Comment 8

13 years ago
Checkin done, thanks. Joe, if you can confirm that you've tested this to work
later on, I'd appreciate it.

/cvsroot/mozilla/webtools/bugzilla/contrib/bugzilla-submit/bugdata.txt,v  <-- 
bugdata.txt
new revision: 1.2; previous revision: 1.1
/cvsroot/mozilla/webtools/bugzilla/contrib/bugzilla-submit/bugzilla-submit,v 
<--  bugzilla-submit
new revision: 1.3; previous revision: 1.2
/cvsroot/mozilla/webtools/bugzilla/contrib/bugzilla-submit/bugzilla-submit.xml,v
 <--  bugzilla-submit.xml
new revision: 1.3; previous revision: 1.2

Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
(Reporter)

Comment 9

13 years ago
kiko, I've tested the checked in version and it works fine. Thanks!

Comment 10

13 years ago
This is a suggestion not only for this bug but also for the general.

Since on the description and additional comments list, there are always "reply"
shown, when you click into it, the description or the additional comments will
automatically repeat again in the column of Additional Comments. 

Is it better to have a optional feature for not repeat?
(Assignee)

Comment 11

13 years ago
Cheryl, could you explain further what you mean?
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.