Closed Bug 230133 Opened 16 years ago Closed 16 years ago

Fixed background in table cell destroys cell layout completely

Categories

(Core :: Layout: Tables, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 195291

People

(Reporter: pieter.v, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208

Fixed background in table cell destroys cell layout completely

A table cell containing a background with this CSS:
border-left: 1px solid #000;
border-right: 1px solid #000;
border-bottom: 1px solid #000; 
border-top: 1px solid #000; 
vertical-align: top; 
background-attachment: fixed;
background-image: url(picture2.jpg);
background-color: #E5E0D4;

has these problems:
- the vertical black border line stops where the text in the cell stops
- picture2 stops at the same place (Instead, #E5E0D4 is shown on Win32, cell is
transparent on Linux).
- Win32: not even the background is shown below the text in the cell if the
browser window containing this HTLM is made very small and the page is scrolled
down (-> transparent).

This is only visible if a cell next to the problem cell has more text so the
table is high enough.

Reproducible: Always

Steps to Reproduce:
Open the attached example file "background.html" (table with 2 columns)

Actual Results:  
The background image and the vertical border lines are only visible in the part
of the cell that contains text.  The cell is transparent after scrolling down.

Expected Results:  
Show the background image in the entire cell, show the border lines around the
entire cell.
The problem is visible without a background image so no image is added.
cc'ing bernd and fantasai for table issue.
Assignee: dbaron → nobody
Component: Style System (CSS) → Layout: Tables
QA Contact: ian → core.layout.tables
Keywords: testcase
border-collapsing issue.... 
Depends on: 4510
bz, there's no border-collapsing in the testcase; it's using the separate model.

I suspect this is a duplicate of bug 195291

*** This bug has been marked as a duplicate of 195291 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.