Closed Bug 230421 Opened 17 years ago Closed 17 years ago

Unescape %xx-escaped URL in location bar when it is safe

Categories

(SeaMonkey :: Location Bar, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 105909

People

(Reporter: isaachh, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ko-KR; rv:1.7a) Gecko/20040108
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ko-KR; rv:1.7a) Gecko/20040108

When native characters in URL are escaped used in the <a href="...">, hovering
the link provides unescaped form in the status bar. This is a good behavior.

But when I click the link and actually load it, the location bar retains the
original escaped form.

I believe location bar should provide human-readable and memorable clue about
current page. When unescaping URL is not dangerous (e.g. URL spoofing), it would
be better to restore them to the native form, in location bar and some other
places, such as bookmark and history URL entries.

This has some practical use in a Wiki page, e.g.
http://wiki.kldp.org/wiki.php/%C0%C0%BF%EB%C7%C1%B7%CE%B1%D7%B7%A5 , where URL
is composed of key terms of the page.


Reproducible: Always

Steps to Reproduce:
1. Hover the URL link with mouse and see the status bar
2. Click the URL and see the location bar
3.

Actual Results:  
Status Bar: http://www.google.co.kr/search?q=테스트&ie=UTF-8&oe=UTF-8&hl=ko
URL Bar:   
http://www.google.co.kr/search?q=%ED%85%8C%EC%8A%A4%ED%8A%B8&ie=UTF-8&oe=UTF-8&hl=ko


Expected Results:  
Status Bar: http://www.google.co.kr/search?q=테스트&ie=UTF-8&oe=UTF-8&hl=ko
URL Bar:    http://www.google.co.kr/search?q=테스트&ie=UTF-8&oe=UTF-8&hl=ko

*** This bug has been marked as a duplicate of 105909 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.