"unblock cookies from this site" adds the site to the list of "always accept cookies from this site"

VERIFIED DUPLICATE of bug 205541

Status

()

VERIFIED DUPLICATE of bug 205541
15 years ago
15 years ago

People

(Reporter: soslow, Assigned: darin.moz)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

If cookies for a site are blocked, choosing "unblock cookies from this site" in
the cookie manager submenu does unblock the cookies, but also adds the site to
the list of domains that are always allowed to set cookies ("site can set
cookies" in the cookie manager), rather than removing it from both blocked and
blocked lists and reverting to "ask the user" behaviour.


Reproducible: Always

Steps to Reproduce:
1.Select "Tools" menu > "Cookie manager" submenu > "Block cookies from this site"
2.Select "Tools" menu > "Cookie manager" submenu > "Unblock cookies from this site"

Actual Results:  
The site is removed from the blocked cookies list but is now listed in the
cookie manager as "Site can set cookies" (ie. cookies are always accepted from
this site).

Expected Results:  
Removed the site from the blocked cookies list ("Site cannot set cookies" in the
cookie manager) only.

The problem can be corrected by opening the cookie manager and manually removing
the site's "site can set cookies" permission.

Comment 1

15 years ago
Dup of bug 205541. Try recent 1.6b, and there is a new "Use Default Cookie
Setting" menu-item.
note that the text now reads "Allow cookies from this site", which clears any doubt

*** This bug has been marked as a duplicate of 205541 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
V/dupe.
Status: RESOLVED → VERIFIED
QA Contact: cookieqa → benc
You need to log in before you can comment on or make changes to this bug.