[PP]Image Inspector crashes Viewer if selected.

RESOLVED WONTFIX

Status

Core Graveyard
Viewer App
P1
normal
RESOLVED WONTFIX
20 years ago
10 years ago

People

(Reporter: Eli Goldberg, Assigned: buster)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
* TITLE/SUMMARY
Image Inspector crashes Viewer if selected.

* STEPS TO REPRODUCE
0) Launch Viewer
1) Select "Image Inspector"

* RESULT
 - What happened

App crashes, both on pages with or without images. [Mac stack crawl enclosed.]

 - What was expected

Damned if I know. ;)


* REGRESSION

 - Occurs On
        viewer (1.12.98 optimized build for Mac OS)
        viewer (whatever debug build was running on sfraser's Mac today)
        viewer (1.12.98 optimized build for Win32)

[Will check Linux and append]


* MACSBUG LOG

 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  0BA8565C
  03B4A280    PPC  0BA7C330
  03B4A220    PPC  0BA7BC1C
  03B4A1E0    PPC  0B75024C  nsMacMessageSink::DispatchMenuCommand(EventRecord&,
long)+004FC
  03B4A100    PPC  0B750720  nsMacMessageSink::DispatchMenuCommand(EventRecord&,
long)+009D0
  03B4A0A0    PPC  0B935350  LPeriodical::DevoteTimeToRepeaters(const
EventRecord&)+00048
  03B4A040    PPC  0B9FA638  TimerPeriodical::SpendTime(const EventRecord&)+00064
  03B49FE0    PPC  0B9FA24C  TimerImpl::Fire()+00024
  03B49FA0    PPC  0B826BF4  NS_OpenURL(nsIURL*, nsIInputStream**,
nsIStreamListener*)+0016C
  03B49F60    PPC  0B8086E8  NET_RegisterProtocolImplementation+05900
  03B49F10    PPC  0B804990  NET_RegisterProtocolImplementation+01BA8
  03B49B80    PPC  0B8102B8  TimingElapsedTimeToString+06C58
  03B49B30    PPC  0B829080  NS_ShutdownINetService+0232C
  03B49A90    PPC  0B50D7A8
  03B49A30    PPC  0B50C8C0
  03B499E0    PPC  0B50C954
  03B49990    PPC  0B513ED4  NS_NewThrobberFactory+037A0
  03B498B0    PPC  0BA840E8
  03B49860    PPC  0BA8516C
PowerPC access exception at 9331B434
(Reporter)

Comment 1

20 years ago
[menu item not present on Linux 1.12.98 build, so no crash. ;-]

Updated

20 years ago
Assignee: rods → buster
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

20 years ago
rod generously added this dialog for the editor group to begin testing of the
editor via HTML dialogs.  Unfortunately, I think this is premature.  So I'm
removing the menu items that invoke these test dialogs for now.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
OS: All → Mac System 8.5
Hardware: All → Macintosh
(Reporter)

Comment 3

20 years ago
Re-opening, since menu item still present and crashing on 1.20.99 Mac OS build
(gone on 1.19.99 Win32 build.) Platform changed to Mac.

I defer to your judgment on whether to fix or ignore (especially if the menu item
is expected to work prior to the next 'developer seeding'-like build ;)

Thanks!
(Assignee)

Comment 4

20 years ago
for now, please remove the menu items from the UI on Mac.  they are not used
yet, and if they ever will be used it will just be for testing purposes only.
(Reporter)

Updated

20 years ago
Resolution: FIXED → ---
(Assignee)

Comment 5

20 years ago
Didactic aside:
You can verify changes in the cell map as a result of incremental reflow by
adding a call to DumpCellMap() in nsTableFrame::Reflow(), just before the return
at the end of the method.
(Assignee)

Comment 6

20 years ago
darn this bugzilla interface...the previous comment belongs to another bug.
please disregard.

Comment 7

20 years ago
Setting all current Open/Normal to M4.
(Assignee)

Comment 8

20 years ago
changed misc bugs to M6

Updated

20 years ago
Summary: Image Inspector crashes Viewer if selected. → [PP]Image Inspector crashes Viewer if selected.
(Assignee)

Comment 9

19 years ago
setting my table bugs to M9

Comment 10

19 years ago
is this still a bug?  note: It's not a table bug.
eli? buster?
(Assignee)

Comment 11

19 years ago
I thought this was fixed long ago.  My comment from 1/20 is most
pertinent...this was debug only, is now unnecessary, and should just be removed
by someone who knows how to remove menu items from mac, if not already done.
(Reporter)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago19 years ago
Resolution: --- → REMIND
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

19 years ago
Hmm...

I'm going to stick my foot out, and resolve this as REMIND, since Viewer is no
longer relevant, and this bug doesn't block testers from using it as a baseline
layout comparison tool.

Any objections, please re-open.
REMIND is deprecated per bug 35839.
Status: VERIFIED → REOPENED
Resolution: REMIND → ---
I think WONTFIX is appropriate, then.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago16 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.