Preventing JavaScript loads from another host

VERIFIED DUPLICATE of bug 94035

Status

--
enhancement
VERIFIED DUPLICATE of bug 94035
15 years ago
14 years ago

People

(Reporter: bertrand.denoix, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

It seems some sites are bypassing the "Accept images from the originating
server" block by loading a bogus JavaScript file instead. Should another setting
be added? Should a more general "Dont't load anything from other servers" (which
would include CSS, Flash, videos, sounds...) be considered?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
possibly dupe of bug 94035 ?
This would also be fixed by the upcoming content policy changes; then one could
write a little content policy plugin to handle this case.
(Reporter)

Comment 3

15 years ago
Yes, it's a dupe of #94035, which even talks about blocking JavaScript, and
unfortunately a pretty  good reason to not do it.

*** This bug has been marked as a duplicate of 94035 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.