Closed Bug 230683 Opened 21 years ago Closed 21 years ago

Font-family dropdown menu not updated

Categories

(SeaMonkey :: Composer, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glazou, Assigned: glazou)

References

Details

Attachments

(1 file, 1 obsolete file)

1. launch seamonkey messenger
2. compose a HTML message
3. type some chars
4. switch to "Fixed width" font through the format toolbar's dropdown
5. type some more chars
6. place the caret anywhere before the fixed width chars

EXPECTED RESULT : "Variable width"
ACTUAL RESULT   : "Fixed width"

That's because the getter of nsFontFaceCommand miserably fails setting the state
attribute. Fix pending.

This bug affects Seamonkey, Thunderbird and Nvu...
Attached patch fix #1 (obsolete) — Splinter Review
Attachment #138866 - Flags: superreview?(sspitzer)
Attachment #138866 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #138866 - Flags: review?(neil.parkwaycc.co.uk) → review+
Comment on attachment 138866 [details] [diff] [review]
better, thanks to Neil

sr=sspitzer
Attachment #138866 - Flags: superreview?(sspitzer) → superreview+
scott would want this for the tbird branch, right?
checked in (trunk)
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
This caused bug 231001 (and presumably broke whatever other consumers were
correctly getting that attribute as a wstring).
Blocks: m6
fixed on the M4 thunderbird branch.
*** Bug 232432 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: