Unable to change ACL of my IMAP folder

RESOLVED DUPLICATE of bug 207628

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 207628
15 years ago
10 years ago

People

(Reporter: Jiri Demel, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

ozilla displays that I have "Full control" but there is no button "Privileges"
(which is promised by Help). The prI am not able to change ACL of my IMAP
folder. The server is Cyrus IMAP 2.1.15.
I have ACL lrswipcda, moblem is in Mozilla, since I successfully changed ACL for
the same mailbox by SquirrelMail.



Reproducible: Always

Steps to Reproduce:
1. Highlit the folder name
2. Edit / Folder properties / Sharing

The same I see after RightClick on folder name and Properties / Sharing.



Expected Results:  
In Help there is:
Click Privileges. You may be prompted to enter your network user name and password.

The Privileges button is only available if the IMAP mail server allows you to
set folder sharing privileges. If this button is not available, you can view the
folder sharing privileges for this folder but cannot change them.

I verified that I am able to change 

Remark: snapshot included with bug #160291 also has no "Privileges" button an I
can see similar inconsistency in reporting ACL.

The same result in Mozilla 1.6b in Win98.
(Assignee)

Comment 1

15 years ago
your server doesn't support the admin url extension required to set the
privileges. This is an http url returned by the imap server which takes the user
to an admin web page that lets the user change imap acl.
*** Bug 230820 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

15 years ago
It means that Mozilla is unable to send SETACL command  as defined in rfc2086?

Changing ACLs by a cgi script is of course possible, but it is imho outside of
the (extended) IMAP protocol. In what form should a server tell Mozilla the url
of the "administrative web page". Is there a rfc document which specifies the
admin url extension?

In any case, if Mozilla rely on some thing outside the IMAP protocol, it should
be mentioned in the Help. And the mention about "Privileges" button removed.
(Assignee)

Comment 4

15 years ago
> It means that Mozilla is unable to send SETACL command  as defined in rfc2086?
Correct.

There are two imap extensions:

One is XSERVERINFO - the syntax is

XSERVERINFO MANAGEACCOUNTURL MANAGELISTSURL MANAGEFILTERSURL

which requests a list of urls (strings, possibly empty) that allow the user to
respectively, manage their account, manage mailing lists, and server side filters.

The other is XMAILBOXINFO <folder name> 

this returns, optionally, MANAGEURL <url string>, and POSTURL <url string>,
which can be used to set ACL for a folder, and post a message to a folder (I
don't believe the latter is used).

I don't know if the Netscape server folks who implemented this wrote up an RFC
or not.
(Assignee)

Comment 5

15 years ago
dup of 207628

*** This bug has been marked as a duplicate of 207628 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.