broken XML encoding not flagged

RESOLVED DUPLICATE of bug 174351

Status

()

--
major
RESOLVED DUPLICATE of bug 174351
15 years ago
15 years ago

People

(Reporter: julian.reschke, Assigned: hjtoi-bugzilla)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Opening XML content with missing encoding declaration doesn't flag an error
(instead, it seems that Mozilla just assumes something like ISO Latin). Instead,
an error should be displayed (this ois a fatal XML parsing problem!).

Reproducible: Always

Steps to Reproduce:
(see attachment)

Actual Results:  
XML source tree is displayed.

Expected Results:  
Display parsing error.
(Reporter)

Comment 1

15 years ago
Created attachment 138967 [details]
sample for broken XML that is accepted
> Opening XML content with missing encoding declaration doesn't flag an error

Nor should it.  The encoding decl is optional for UTF-8 content.

Now this content is not UTF-8, and we don't flag _that_ as an error.  That's a
bug.  I thought we had it filed, but we don't seem to.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
I think you mean bug 174351
(Reporter)

Comment 4

15 years ago
Just confirming: yes, this is about non-UTF-8 content without XML declaration.

*** This bug has been marked as a duplicate of 174351 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.