History should not store invalid URLs

RESOLVED DUPLICATE of bug 9203

Status

()

Core
History: Global
RESOLVED DUPLICATE of bug 9203
15 years ago
15 years ago

People

(Reporter: David Escott, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031205 Galeon/1.3.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031205 Galeon/1.3.10

An invalid URL (say "nyti") is stored in the users history. This should not
happen, appropriate behavior would be to take all 4XX errors and not place those
in the history.

This makes autocompletion of history a obnoxiously annoying task, especially
with regard to some other application built on mozilla (both galeon and
epiphany). Scenario: After having visited nytimes.com once it is common to want
to do nyti[TAB][ENTER] to get to nytimes.com. This works fine but if one
mistakenly hits [ENTER] before [TAB] mozilla goes to the invalid nyti or
nyti.com now one can no longer quickly get to nytimes.com because typing
nyti[TAB][ENTER] takes the user to the invalid "nyti".

Reproducible: Always

Steps to Reproduce:
1.Go to nytimes.com
2.Then go to nyti
3.Now try to quickly get to nytimes.com by typing nyti[TAB][ENTER]


Expected Results:  
Ignored the invalid nyti and gone to nytimes.com

Comment 1

15 years ago
Duping, please reopen if you disagree.

*** This bug has been marked as a duplicate of 9203 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.