Bookmarks divider (splitter) does not remember state

RESOLVED FIXED in Camino0.9

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: wtmcgee, Assigned: sfraser_bugs)

Tracking

unspecified
Camino0.9
PowerPC
macOS

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040115 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040115 Camino/0.7+

something i have noticed lately is that the bookmark manager does not remember
it's state between sessions. for example, if i move the bar dividing the
categories (top 10, menu bar, history, etc) farther to the left, then close
window i'm working in, next time i use the bookmarks manager, the view is at
it's default state.

this also applies to the bar at the bottom, with search results


Reproducible: Always

Steps to Reproduce:
1.open bookmarks manager
2.adjust the position or size of a window in the bookmarks manager
3.close the window
4.note the window sizes are at their default again.

Actual Results:  
the window sizes did not save their state

Expected Results:  
the sizes and positions of the colums in the bookmarks manager should be
retained between sessions.
i checked in the other change slider fix already, morphing this to the work that
remains.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Bookmarks manager does not remember state → Search results slider does not remember state
Target Milestone: --- → Camino1.0

Comment 2

14 years ago
Changing summary as we no longer have a results view. But the root bookmarks
dividers still doesn't save it's coordinates.
Summary: Search results slider does not remember state → Root bookmarks divider does not remember state
(Assignee)

Comment 3

14 years ago
Taking.
Assignee: pinkerton → sfraser_bugs
Status: ASSIGNED → NEW
*** Bug 294672 has been marked as a duplicate of this bug. ***
i *swear* this worked in 0.8. what's up?
(Assignee)

Comment 6

14 years ago
What's up is that ther's a method, -focus, where the splitter state is restored,
is not called any more after my 'content view provider' changes, because the BM
view controller doesn't actually know when the bm view is added to the window,
and hence sized correctly. Though I guess it could cue off a -viewDidMoveToWindow.
Status: NEW → ASSIGNED
Summary: Root bookmarks divider does not remember state → Bookmarks divider (splitter) does not remember state
Simon, since you know "what's up", is this easily fixable?
(Assignee)

Comment 8

14 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: Camino1.0 → Camino0.9
You need to log in before you can comment on or make changes to this bug.