SVG doesn't work in HTML <embed> tag

RESOLVED DUPLICATE of bug 240408

Status

()

RESOLVED DUPLICATE of bug 240408
15 years ago
14 years ago

People

(Reporter: blue_prawn, Assigned: alex)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031217

Mozilla should support both of them ! 
 
<embed src="./svg.xml" type="image/svg+xml" />  
<object data="./svg.xml" type="image/svg+xml" /> 
 
embed is for HTML 4 and 4.01 
object is for XHTML 1.0 and 1.1 
 

Reproducible: Always

Steps to Reproduce:
1. switch the DOCTYPE of XHTML1 to HTML4 
2. switch the tag to include the SVG image 
Actual Results:  
HTML does not work (only XHTML) 
 

Expected Results:  
interoperability with HTML (not only XHTML)
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: in XHTML1.0 -> object tag /VS/ in HTML4.01 -> embed tag → SVG doesn't work in HTML <embed> tag

Updated

14 years ago
OS: Linux → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 240408 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.