Download finished alert pop-up should re-open Download Manager window when clicked

VERIFIED DUPLICATE of bug 229062

Status

()

Toolkit
Downloads API
--
enhancement
VERIFIED DUPLICATE of bug 229062
15 years ago
10 years ago

People

(Reporter: Matthew Kerr, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20040102 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20040102 Firebird/0.7+

In the current behavior with the download manager taking over all downloading,
instead of specific windows per download like the old behavior, you end up with
a situation where the end of a download results in a pop-up alert (similar to
the new mail alert in Thunderbird) that has a blue underlined text that appears
to be a hyper-link-- you'd expect it to be click-able such that it would bring
up the download manager if you had either closed or minimized it, but it
doesn't. (yes, it's a run-on sentence)

Reproducible: Always

Steps to Reproduce:
1. Download a file with the download manager.
2. Close or minimize the download manager.
3. Wait until it finishes, and try to click the linked text on the download
finished alert.

Actual Results:  
The link in the pop-up alert doesn't do anything...

Expected Results:  
Opened the download manager if it was closed, or focused and raised it if it was
minimized.

Comment 1

15 years ago
I'd like to see this too.
Severity: minor → enhancement
Summary: download finished alert pop-up should re-open download manager window → Download finished alert pop-up should re-open Download Manager window when clicked

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 229062 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
QA Contact: aebrahim
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.