Closed Bug 231379 Opened 21 years ago Closed 19 years ago

auto height too small for content

Categories

(Core :: Layout: Positioned, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: garym, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

In the _current_ main page of http://www.teledyn.com/mt/ (Jan 18 2004) the main
section of the page ceases to render after the item ":: The New Gleaners ::"
although view source shows that there are many items beyond that post, and the
entire page renders in Mozilla 1.5.  Since these items are all posted from the
identical template (MovableType) it is unlikely that the basic structure of the
page is corrupt (unclosed DIV or something) and an inspection of the source code
does not show anything peculiar, yet repeated attempts and reloads with 1.6
always ceases to render the page after this post.

Reproducible: Always

Steps to Reproduce:
1. load http://www.teledyn.com/mt 
2.
3.



Expected Results:  
see the same page in Mozilla 1.5/Linux

I will follow this post with an upload of the page source as seen by the 1.6
page-save.  This is a potentially serious bug since there is no indication that
content is missing from the page; an inexperienced user would simply conclude
that the page ended at that point.
the HTML is perhaps not the culprit since the page when loaded without the CSS
is rendering the simple page in its complete form --- the CSS will be attached
later -- when viewed with the CSS, the page gets truncated at that same place.
This stylesheet rendered fine in Mozilla 1.5 and before, but mysteriously gives
up half way through the main blog content when seen in 1.6
Confirming bug, 2004-01-16-08 trunk Linux.

The relevant styling is: position:absolute; overflow:hidden; height:auto;
The computed height is ~2057px which is too small to fit the content.
(In Mozilla 1.5 the computed height is ~4015px)
Assignee: parser → nobody
Severity: critical → major
Status: UNCONFIRMED → NEW
Component: HTML: Parser → Layout: R & A Pos
Ever confirmed: true
QA Contact: core.layout.r-and-a-pos
Summary: parsing aborts rendering → auto height too small for content
More of the same issues with scrollframes -- the incremental reflow when more
content does not change the prefsize we got during the initial reflow.  We
should just have a bug to track this problem and mark all these as deps of it...
Attached file Testcase (obsolete) —
Regression occured between the builds 2003-09-15-22 -- 2003-09-18-22,
bug 69355 is in that interval.
Right.  That's because we switched overflow:hidden to scrollframes at that
point.  Before that checkin, the bug was easily reproducible with
overflow:auto/scroll (try it with a 1.5 build).
Attachment #139376 - Attachment is obsolete: true
OK, then the regression occured somewhere between Mozilla 1.3.1 and 1.4
Forget that,  I see now that it occurs all the way back to Mozilla 1.0.2
Just for the record, this bug persists in 1.7 RC1 just downloaded a few moments
ago.  Same test, same result.  I expect you already knew that :)
Depends on: 240276
Testcase#2 fails for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050422 Firefox/1.0+
Testcase#2 works for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050428 Firefox/1.0+
Resolved Fixed by bug 240276
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: