If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

print only one page with position: absolute (but works with position: relative)

RESOLVED DUPLICATE of bug 154892

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 154892
14 years ago
14 years ago

People

(Reporter: Jonathan Baron, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040115
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040115

When I print a long div with "position: absolute;", I get only
one page printed.

This may be related to bugs 179135 and 122750, but it doesn't
seem to be the same.


Reproducible: Always

Steps to Reproduce:
1. print the test page (to file, or print preview, or to printer)
2.
3.

Actual Results:  
only one page printed

Expected Results:  
several pages printed

The problem is fixed by changing "absolute" to "relative" (although
of course this louses up the layout).  This can be seen by comparing
test1.htm to test2.htm, which differ only in test1.css and test2.css,
which differ only in whether the position is absolute or relative.
Specifically, the two pages are:
http://www.sas.upenn.edu/~baron/test1.htm
http://www.sas.upenn.edu/~baron/test2.htm

*** This bug has been marked as a duplicate of 154892 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.