Cairo rendering backend for SVG

RESOLVED FIXED

Status

()

RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: tor, Assigned: tor)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

8.94 KB, patch
alex
: review+
bryner
: superreview+
chofmann
: approval1.7a+
Details | Diff | Splinter Review
(Assignee)

Description

15 years ago
First cut of Cairo rendering backend has been checked into the SVG branch.
Works except for regions (waiting for Cairo functionality) and fonts.

Attached is a patch that needs to be applied atop the branch to enable
build/use of the new backend.
(Assignee)

Comment 1

15 years ago
Created attachment 139502 [details] [diff] [review]
hook up cairo
(Assignee)

Comment 2

15 years ago
Created attachment 139513 [details] [diff] [review]
fix copy/paste error
Attachment #139502 - Attachment is obsolete: true
(Assignee)

Comment 3

15 years ago
Comment on attachment 139513 [details] [diff] [review]
fix copy/paste error

Patch now applies to the trunk.  Would like to get this in for 1.7a.
Attachment #139513 - Flags: superreview?(bryner)
Attachment #139513 - Flags: review?(alex)

Comment 4

15 years ago
Comment on attachment 139513 [details] [diff] [review]
fix copy/paste error

Looks good. r=afri.
Does this preprocessor arithmetic work on all platforms, though?

#if(defined(MOZ_SVG_RENDERER_GDIPLUS)+
defined(MOZ_SVG_RENDERER_LIBART)+ 
defined(MOZ_SVG_RENDERER_CAIRO) > 1)
Attachment #139513 - Flags: review?(alex) → review+
Attachment #139513 - Flags: superreview?(bryner) → superreview+
(Assignee)

Comment 5

15 years ago
Comment on attachment 139513 [details] [diff] [review]
fix copy/paste error

Requesting 1.7a approval.  Not part of the default build, just the 
build config and other changes needed to allow work on a new rendering
backend to SVG.
Attachment #139513 - Flags: approval1.7a?

Comment 6

15 years ago
Comment on attachment 139513 [details] [diff] [review]
fix copy/paste error

a=chofmann
Attachment #139513 - Flags: approval1.7a? → approval1.7a+
(Assignee)

Comment 7

15 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Duplicate of this bug: 83631
You need to log in before you can comment on or make changes to this bug.