select: onchange doesn't run if you change the value with the keybord but runs with the mouse

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Event Handling
--
minor
RESOLVED DUPLICATE of bug 126379
14 years ago
14 years ago

People

(Reporter: leirn, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)
Build Identifier: "Firebird/0.7"

I use a html code like this one. If i change the value of "mois" with the 
mouse, check_date runs. If i change it with the keyboard, it doesn't.

<script type="text/javascript"><!--
function check_date()
{	
//some commands
}
//-->
</script>

<form>
<select name="mois" onchange="check_date()">
		<option value="01">...</option>
		<option value="02">...</option>
</select>
</form>

Reproducible: Always

Steps to Reproduce:
1.Load a similar page
2.Try to mofify mois with the keyboard

Actual Results:  
The function doesn't run in the second case

Expected Results:  
Mozilla should have run the script in each case
onchange should fire when the <select> loses focus. does it?

Comment 2

14 years ago
Dupe of 126379.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.