[OS/2] Text rendering glitches when coming from cache

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: relf, Assigned: roc)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
OS/2 build 2004012108

To reproduce just open provided URL in a new tab/window. There are some weird
effects like overlapping of the text from different parts of the page. 
Try to select/scroll the text, reload the page etc.

Linux build 2004012207 works fine.
(Reporter)

Updated

15 years ago
Component: Layout: View Rendering → Layout
(Reporter)

Comment 1

15 years ago
I've just crated a new profile and found out that for the *very first* time the
page is shown Ok. 
If I clear the cache prior to openning the page, it's rendered fine as well.

But subsequent reloading brings glitches on in both cases.
Summary: [OS/2] Text rendering glitches → [OS/2] Text rendering glitches when coming from cache

Comment 2

15 years ago
WFM in same build with ft2lib installed.
(Reporter)

Comment 3

15 years ago
No ft2lib installed here.
Please attach a screenshot
(Reporter)

Comment 5

15 years ago
I've found the reason - PMMERGE.DLL recently appeared on testcase in 28131.zip.

It happens that Mozilla first displays top part of the page and then jumps to
#label and over-displays the page starting from the label. Testcase PMMERGE.DLL
doesn't completely replace previous window content leaving some mess.

With default PMMERGE.DLL everything works fine.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.