Incorrect display of Greek koppa (U+03DE and U+03DF)

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: peter, Unassigned)

Tracking

({intl, testcase})

Trunk
x86
Windows 2000
intl, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

The Unicode characters U+03DE GREEK LETTER KOPPA and U+03DF GREEK SMALL LETTER
KOPPA are displayed incorrectly in the default font. The glyphs displayed are
those for U+03D8 GREEK LETTER ARCHAIC KOPPA and U+03D9 GREEK SMALL LETTER
ARCHAIC KOPPA respectively. These glyphs are similar to Q with a centred tail;
the correct glyphs resemble a lightning bolt sign. U+03D8 and U+03D9 are
displayed correctly but with slightly different glyphs.

Strangely enough, when the font size is increased (in Composer which
demonstrates the same problem), the correct glyph appears for U+03DF, but the
glyph for U+03DE remains incorrect. The correct glyph also sometimes appears in
the browser at the default size.

For the correct glyphs, see http://www.unicode.org/charts/PDF/U0370.pdf (Unicode
reference glyphs) or fonts Code2000 or TITUS Cyberbit Basic. (Arial Unicode MS
is also incorrect.)

Reproducible: Always

Steps to Reproduce:
View the page which I will attach. U+03DE is consistently displayed wrong.
U+03DF sometimes appears correctly (lightning bolt); edit the page with Composer
and reduce the font size, and the incorrect glyph (Q shape) will appear.
Actual Results:  
U+03DE is displayed with the wrong, Q-shaped glyph. U+03DF is sometimes also
displayed wrong.

Expected Results:  
Displayed U+03DE and U+03DF with the default lightning bolt glyphs.

I thought at first that this was a problem with a font on my system. But the
incorrect glyphs don't seem to be in any of my fonts, which suggests that they
are being produced by Mozilla internal code.

These koppa characters are used for numerals in modern Greek. A koppa displayed
with the archaic glyph is not recognised by most contemporary Greeks. See
http://www.tlg.uci.edu/~opoudjis/unicode/numerals.html#koppa for further details.
(Reporter)

Comment 1

15 years ago
Created attachment 139698 [details]
HTML demonstrating the bug

This HTML consists of the four Unicode variants of Greek koppa, with their
codes. 03DE and sometimes 03DF display incorrectly.
Are you sure this isn't a bug in one of your fonts?
(Reporter)

Comment 3

15 years ago
No - but which font? I have over 1000 installed on my system (which by the way
makes the font selection procedure in Composer EXTREMELY slow) and I can't check
all of them. I have checked all the fonts named for Greek, western, Unicode etc
in about:config, and the glyphs displayed come from none of them. When I copy
and paste this text from Mozilla into another application it seems that no font
information is put on the clipboard. Is there any mechanism in Mozilla for
determining which font is in use for a particular character? And the font used
by default for most variable width text in Mozilla doesn't seem to be any of my
regular system fonts. The font which is used has other problems e.g. that it
forms fi ligatures by default, which makes it unusable for Turkish (which needs
to distinguish <f,i> from <f, dotless i>).

Updated

15 years ago
Keywords: testcase

Comment 4

15 years ago
With lang="el" specified and 'Code2000' specified for Greek, I got U+03DE and
U+03DF right. However, if not, I got them wrong in Mozilla-Xft. Glyphs for
U+03D8 and U+03D9 are slightly different from glyphs for U+03DE and U+03DF,
which indicates that they come from different fonts. 
I guess somewhere 'transliteration' is at work. I'll check it out later.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
I did some more testing and concluded that it has nothing to do with
transliteration done by Mozilla. Fonts are to blame. When Code2000 is 
explicitly specified, all four characters at issue here are rendered as they should.

> Arial Unicode MS is also incorrect.

> But the incorrect glyphs don't seem to be in any of my fonts

 Are you sure U+03DE is not rendered with Arial Unicode MS? It has the wrong
glyph for U+03DE while it (at least my copy) doesn't cover U+03DF.

> I have checked all the fonts named for Greek, western, Unicode etc
> in about:config, and the glyphs displayed come from none of them.

  Does any of them cover U+03DE and U+03DF? What happens if you specify Code2000
for Greek in Edit|Preference|Appearence|Font|Greek (for all five categories)? 

> the font used by default for most variable width text in Mozilla doesn't 
> seem to be any of my regular system fonts. 

  Fonts used are what _you_ specify in Edit|Preference|Appearance|Fonts.
Mozilla-Win doesn't have a mechanism to read your system font setting to set the
default font. If you think the feature is necessary, you have to file a
_separate_ bug. 

> The font which is used has other problems e.g. that it
> forms fi ligatures by default, which makes it unusable for Turkish 
> (which needs to distinguish <f,i> from <f, dotless i>).

  You're trying to dump all font related problems here. Let's deal with them one
by one in separate bugs. Anyway, in case of Turkish, how could Mozilla know if
'f i' sequence is in Turkish?  You have to tell it that it's Turkish with 'lang'
and/or 'xml:lang' and set fonts for Turkish to those that don't use 'fi
ligature' by default. 

Keywords: intl
(Reporter)

Comment 6

15 years ago
Thanks for comment 5.

I now think that 03DE was being rendered with Arial Unicode MS (hence the
incorrect glyph). It looks as if the incorrect glyph for 03DF was being picked
up from Vusillus Old Face, which was NOT one of the fonts listed in my
about:config, but I guess that if the system couldn't find a glyph in any of the
listed fonts it chose one at random (perhaps the last one in the alphabet).
Either Mozilla or Windows must have some mechanism which does this.

By changing all the fonts for Greek to Code2000 I now get a correct display of
my  test page. But it messes up my display of Greek text: I get Arial glyphs for
unaccented characters but Code2000 glyphs for all accented ones. Well, I guess I
can get round that by a careful choice of fonts.

I mentioned the fi ligature here because it might help to determine which font
is being used. I am still confused by this. But we can probably close this bug.
Sorry to waste your time.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.