bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

No error given when imap offline download fails because server drops the connection



MailNews Core
Networking: IMAP
14 years ago
24 days ago


(Reporter: Everette Mills, Unassigned)


1.7 Branch
Windows 2000
Bug Flags:
blocking-thunderbird3.0a2 -
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)



(1 attachment)



14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla Thunderbird 0.5a (20040120

1.All of my folders where marked for offline use
2.*.msf file created for every folder
3. mbox message store only created for folders which I have looked in.

I have found this problem in both TB and Mozilla Mail.

Reproducible: Always

Steps to Reproduce:

Actual Results:  
Only partial download of messages to offline store

Expected Results:  
SHould have downloaded all of the messages to offline storage.


14 years ago
Assignee: mscott → bienvenu
Component: Mail Window Front End → Offline
Product: Thunderbird → MailNews
QA Contact: grylchan
Version: unspecified → 1.0 Branch

Comment 1

14 years ago
did you do a File | Offline | Download & Sync Now, while online? That's what
causes messages to get downloaded for offline use.

Comment 2

14 years ago
This may be the cause of my problem, but the offline option is not on my menu.  
I have subscribe, which just brings up a list of folders to which I can join.  
Otherwise nothing related to offline use.

Comment 3

14 years ago
You need to install the offline extension to thunderbird before you get the
offline features. If you go into options | extensions, and click on get new
extensions, the page that comes up in the browser will have a link for the
offline extension at the top of the page. I'm going to mark this invalid - but
if you have installed the offline extension, and you're not seeing the menu
item, please re-open.
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 4

14 years ago
I have installed the extension. (side not, not accesible through main webpage)

I have a similar problem.

I select the download/sync.  

All of my folders are selected and it only gets the mail for 1 or 2.

I have approx. 50 folders and all of them are selected for download.
An mbox files was created for all of them, but it is empty for all but 10.  
There are files in each of these.

Is there a problem with subfolders?
Resolution: INVALID → ---

Comment 5

14 years ago
could you attach an imap protocol log of what happens when you do a file |
offline | download and sync now by following these instructions?


Comment 6

14 years ago
Created attachment 139738 [details]
IMAP Log 2004-01-23

Log of IMAP activities including a request for download of all messages as

Please let me know if you need any additional information.

Comment 7

14 years ago
Everette, from the log, it looks like your server is dropping the connection.
Can you go into the advanced imap server properties (tools | Account Settings |
server settings | Advanced) and change maximum number of server connections to
cache to 3 or 4? I think by default, Courier only allows 4, and after that
starts dropping the connection, which causes the whole offline sync to abort.
Ever confirmed: true

Comment 8

14 years ago
After changing imap connections from 5 to 4 process worked smoothly.

All messages were downloaded.
Mbox files were populated for offline work.

Thanks for the assistance.
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 9

14 years ago
The bug is that you weren't notified of the error - there's an existing bug
about not getting notified correctly when this happens with the courier server,
and you should have been told that the going offline process was aborted...I'm
going to re-open this for the latter problem...
Resolution: FIXED → ---


14 years ago
Summary: Offline Folders not download when marked → No error given when imap offline download fails because server drops the connection
Product: Browser → Seamonkey

Comment 10

12 years ago
This "Offline thing" looks real sketchy to me, too. I have to use this a couple of times a week to write mails off our IMAP server on the go, and I could really use either an error when it fails or at least a shiny little "download done" message in the corner so I know when I can pull the plug and get moving.
The missing error message had me sitting in the train a couple of times with nothing to do since messages actually hadn't downloaded. Offline syncing feels very much like voodoo right now.
BTW, when I go offline in TB, close it and start it up again, it's in online mode again. Is this behaviour intended or is this a bug? If the latter, is it an existing bug?
Can you reproduce with SeaMonkey v1.1.9 ?
(or Thunderbird v2.0.0.14 ?)
Component: MailNews: Offline → Networking: IMAP
Product: Mozilla Application Suite → Core
QA Contact: grylchan → networking.imap
Version: 1.0 Branch → 1.7 Branch
Blocks: 274576
Flags: blocking-thunderbird3.0a2?
Not an a2 blocker.
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3.0a2?
Flags: blocking-thunderbird3.0a2-

Comment 13

10 years ago
The problem doesnt appear with one of my email accounts, but does still exist with  version

Comment 14

10 years ago
leaving wanted, marking p2, but I think since we're going to a model where messages will get downloaded for offline use in the background, this may not be as big an issue.
Priority: -- → P2


9 years ago
Product: Core → MailNews Core


4 years ago
See Also: → bug 678947


2 years ago
Duplicate of this bug: 274576


a month ago
See Also: → bug 1281085


24 days ago
Assignee: mozilla → nobody
You need to log in before you can comment on or make changes to this bug.