If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Windows uninstaller cosmetic bug, \n is not escaped in folder name

RESOLVED FIXED in mozilla1.7beta

Status

SeaMonkey
Installer
--
trivial
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Alan Monroe, Assigned: Benjamin Smedberg)

Tracking

Trunk
mozilla1.7beta
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

3.40 KB, image/png
Details
2.78 KB, patch
Ben Goodger (use ben at mozilla dot org for email)
: review+
Ben Goodger (use ben at mozilla dot org for email)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Dialog box reads:
"Not all files were uninstalled from the installation directory:
C:<newline>
et\Mozilla"
when it should read:
"Not all files were uninstalled from the installation directory:
c:\net\Mozilla"


Reproducible: Always

Steps to Reproduce:
Uninstall Mozilla from Add/Remove Programs control panel.
Actual Results:  
The backslash-n turned into a newline.

Expected Results:  
The backslash-n should remain part of the folder name.
(Reporter)

Comment 1

14 years ago
Created attachment 139815 [details]
Screenshot of the newline problem
(Assignee)

Comment 2

14 years ago
This is caused by
http://lxr.mozilla.org/mozilla/source/xpinstall/wizard/windows/uninstall/extra.c#1888

We should switch the calls to _snprintf and ReplacePrivateProfileStrCR. Patch
forthcoming.
Assignee: general → bsmedberg
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

14 years ago
Created attachment 139991 [details] [diff] [review]
Switch _snprintf and ReplacePrivateProfileStrCR
(Assignee)

Updated

14 years ago
Attachment #139991 - Flags: superreview?(bugs)
Attachment #139991 - Flags: review?(bugs)
Comment on attachment 139991 [details] [diff] [review]
Switch _snprintf and ReplacePrivateProfileStrCR

r/sr=ben@mozilla.org
Attachment #139991 - Flags: superreview?(bugs)
Attachment #139991 - Flags: superreview+
Attachment #139991 - Flags: review?(bugs)
Attachment #139991 - Flags: review+
(Assignee)

Comment 5

14 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.7beta
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.