In multiple table with the same CSS background style it does not work properly

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Provolik, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

In the page http://www.archons.it/tablestyle/ you can find an example. Every
table is the exact copy of the first table with the same CSS background style. I
apply a background-image on the table and then anote on the TD. The image of the
table is a gif (yellow color with transparency). The first TD has a black color
with transparency, the second is a white color with transparency and the last ha
no style (so report the table style). However some table hasn't the wanted
layout and  I don't understand why. If you try open that page with explorer 6 it
seems to work properly (if you want see the correct layout)

Reproducible: Always

Steps to Reproduce:
1.
Take the code page from this page example: http://www.archons.it/tablestyle/
and save it as php file (for example index.php) or any other viewing browser
format (htm, html, asp, etc...)
2.
Download the background image files and save those with the original name in the
same directory of the php file of the step one.
3.
Create a CSS file naming it 'stile.css' and save it in the same directory of the
php file. Put in the file this code:

body.body
	{
	background-color: white;
	font-family: verdana, helvetica, arial, sans-serif;
	text-align: center;
	color: #000000;
	font-size: 10pt;
	background: url(logo2rj3d.jpg);
	background-repeat: no-repeat;
	background-position: center;
	background-attachment: fixed;
	margin-top: 0px;
	margin-right: auto;
	margin-bottom: 0px;
	margin-left: auto;
	}
table.novita
	{
	border: outset 1pt;
	background-image: url(semisfondogiallo.gif);
	color: white;
	width: 100%;
	}
td.novitatitolo
	{
	border: inset 1pt;
	background-image: url(semisfondonero.gif);
	}
td.testo
	{
	border: outset 1pt;
	background-image: url(semisfondobianco.gif);
	color: black;
	}

If you think there are some errors in this code let me know...

4.
Launch the page with Firebird Browser
Actual Results:  
Some table has different style from others...

Expected Results:  
All the table must have the same style

I try to view the page (http://www.archons.it/tablestyle/) from Linux with
Firebird o.6 and has the same errors. With Konqueror the page works well, Galeon
instead has same error.
Is this still a problem now that bug 4510 has landed?  All the tables look like
they're the same style to me...

Comment 2

15 years ago
Created attachment 143486 [details]
screenshot - 2004030906

Comment 3

14 years ago
Created attachment 146958 [details]
Testcase

The backgrounds are only a symptom of this bug (although they make the problem
much more visible).  This is a one-pixel error in the table rendering.	The
problem is the space between the table border and the top edge of the cell. 
The space is one pixel different between the tables, causing the transparent
backgrounds to overlap differently.

This can occur with borders in almost anything other than whole pixels (i.e.
.25cm, .1em, .5px), although it takes more tables with some lengths than with
others.

Updated

14 years ago
Keywords: testcase
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007110515 Minefield/3.0a9pre

Looks like fixed to me

Comment 5

9 years ago
this is wfm please reopen if you still see the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.