Missing text message body in message window

RESOLVED INVALID

Status

MailNews Core
MIME
--
major
RESOLVED INVALID
15 years ago
8 months ago

People

(Reporter: Jani Tiainen, Unassigned)

Tracking

({intl, testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla Thunderbird 0.5a (20040120)

There is message body text in message (visible when look message source), but 
doesn't show up in message window. Same message was working correctly with 
version 0.4, but with 0.5a doesn't.



Reproducible: Didn't try
Steps to Reproduce:
1.
2.
3.




This it might something to do with CR/CRLF's.

Comment 1

15 years ago
Could you please attach the source of the message as a text file attachment?
(Reporter)

Comment 2

15 years ago
This bug is hard to reproduce. This only appears on IMAP folders on only one
ISP, and only seen when charset is set to iso-8859-1. If changed to UTF-8 body
is seen again, but then extended characters aren't showing right.

Same message from same ISP via pop3 works fine, so I really think that this is
more like issue in ISPs IMAP... 

Message was cut usually on some (random?) location where some extended character
(äöÄÖ).

Comment 3

13 years ago
Message body text missing:
Source code indicates the following:

Content-Type: text/plain; charset="iso-8859-1"

Content-Transfer-Encoding: 7bit

It is appearing from what I suspect is an automated order status email vice hand
sent.  The text will reappear (sort of) it going to the Thunderbird view menu,
selecting character encoding, then auto0detect and finally clicking on the "NO"
radio button, or going to view source.  If you like I can forward the message to
you or cut & paste the source here.


Also I am using WinXP as my OS with SP2 installed, vice Win 2000 as the original
report.

Thanks

Bob
fitzsimmonsrobert @charter.net

Comment 4

13 years ago
I *THINK* I am having the same problem on my Mac OSX 10.2.8, Thunderbird
"version 1.0.6 (20050716)".  I received the following junk mail (some personal
details removed) which shows no content.  If I switch from "auto-detect
character-encoding OFF" to "auto-detect character-encoding Japanese"  (for
instance) the content appears, albeit poorly formatted.  Switching back to "a-c
c-d OFF" makes the content disappear.

I figured out that there WAS content because I am still evaluating Thunderbirdd,
so I'm still shadowing my email receipts with Mac's "Mail" program, v. 1.2.5
(v553)".  The content shows up there.

Here's the message:

X-Account-Key: account2
X-UIDL: 1125159576.18412.273.xxxxxx014,S=1278
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Received: from xxx.xxx.xxx.xxx (xxx@[xxx.xxx.xxx.xxx])
        by xxx.xxx.xxx.xxx (8.12.11/8.12.11) with SMTP id xxxxxxxxxxxxx
        for <eddiec@MA'AM_starMA'AM_archerMA'AM_.com>; Sat, 27 Aug 2005 12:19:33
-0400
Date:   Sat, 27 Aug 2005 12:19:29 -0400
X-Message-Info: 657zfkFxsxT24KKifsi311pBCUoK63SPZ04kMRouO994
Received: from xxxxxxxx.xxx (104) by xxxxxxxxxx.xxxxx.com with Microsoft
SMTPSVC(5.0.2195.6824);
         Sat, 27 Aug 2005 11:12:54 -0600
Received: from xxxxxxx.xxx (127.0.0.1) by xxxxxxx.xxx
  (SMTPD32-7.12     ) id D3X433; Sat, 27 Aug 2005 14:09:54 -0300
Subject: evaluate this
From:   xxxxxxx@xxxx.xxxx.xxxxxxx.xxx
To:     eddiec@_NOSPAMMA'AM__star_NOSPAMMA'AM__archer_NOSPAM_MA'AM_.com
Message-Id: <04586781.Q017@xxxxxx.xxxx>
Content-Type: multipart/alternative;
        boundary="--7401296653521718222"

----40149039107763552
Content-Type: text/plain;
Content-Transfer-Encoding: 7Bit

 CellBand offers a unique way to carry your cell phone and other devices while
you work and play outdoors. Take a look at our website loc\
ated at " http://www.cellband1.us "
       You will be glad you did!




----7995818912782409457--

----7401296653521718222--


Comment 5

13 years ago
I've noticed a similar problem with a multi-part mime message containing
embedded images and a text attachment when connecting to an IMAP server. In mime
this gives:

multi-part: mixed
---
multi-part: related
---
multi-part: alternative - for the p/t and html parts
---
p/t content
---
html content
---
img contents - for the related parts
---
txt content - for the text attachment

When the message is first viewed from the server in either text or html format,
without 'show attachments inline' set, the message window is blank. When viewed
with attachments shown inline, both the text and html formats work fine. It
appears as though the message download from the server is not happening unless
'show attachments inline' is set.

No such problems occur in POP3 mode.

mark.chimley@identum.com

Comment 6

12 years ago
Created attachment 220918 [details]
Message Body example, which can't be displayed

Neither Thunderbird 1.0.7-1.1.fc4 (Redhat Linux), Thunderbird 1.5.02 (Windows XP) nor SeaMoneky 1.0 (Windows XP) is able to display the attached message body. MS Outlook does ! All of the 3 above display the attached gif-file, the message text is missing !!

Comment 7

12 years ago
Created attachment 223851 [details]
step-by-step walk thru on "won't display mail"

Comment 8

12 years ago
(In reply to comment #5)
> I've noticed a similar problem with a multi-part mime message containing
> embedded images and a text attachment when connecting to an IMAP server. In mime
> this gives:
> 
> multi-part: mixed
> ---
> multi-part: related
> ---
> multi-part: alternative - for the p/t and html parts
> ---
> p/t content
> ---
> html content
> ---
> img contents - for the related parts
> ---
> txt content - for the text attachment
> 
> When the message is first viewed from the server in either text or html format,
> without 'show attachments inline' set, the message window is blank. When viewed
> with attachments shown inline, both the text and html formats work fine. It
> appears as though the message download from the server is not happening unless
> 'show attachments inline' is set.
> 
> No such problems occur in POP3 mode.
> 
> mark.chimley@identum.com

I can confirm that this is still happening in 1.5.0.4. It seems that MS Outlook is quite good at generating these problem e-mails with "no body".

Comment 9

12 years ago
I'm having a similiar problem. I'm an IT officer for a university and a couple of our academics are experiencing the same problem, but only if the mail is sent from outlook. The mails are internal. The body of the message cannot be seen, and if reply is hit, you still cannot see the message body. If you forward the email to yourself, you can then seen what was written.

I have a funny feeling this is also to do with formatting. The email were formatted in outlook, and contained text formatting of pargraphs, headings etc. Perhaps this is the problem?

Comment 10

12 years ago
I've seen this for a while. (Using Win98SE)
I thought it might have been the Perl module I was using.
So I loaded Mozilla Mail to check, same problem.  

When the mixed message of HTML and encoded Excel attachment does not display:
  a) pressing forward message shows the entire contents and attachment
  b) looking at message source then closing the popup,
     sometimes causes the message to be displayed correctly


Here is the header info from the mail created with MIME::Lite.

X-MimeOLE: Produced By Microsoft Exchange V6.0.6603.0
Content-Transfer-Encoding: binary
Content-Type: multipart/related;
	boundary="----=_NextPart_000_514A_01C6A8DE.E3A97EE0"
MIME-Version: 1.0
X-Mailer: MIME::Lite 2.117  (F2.6; A1.59; B3.01; Q3.01)
FILETIME=[3E9B3110:01C6A900]

This is a multi-part message in MIME format.

------=_NextPart_000_514A_01C6A8DE.E3A97EE0
Content-Disposition: inline
Content-Length: 105529
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset="iso-8859-1"

<HTML><BODY><H2>
::::
</BODY>
</HTML>

------=_NextPart_000_514A_01C6A8DE.E3A97EE0
Content-Disposition: attachment;
	filename="FILE.xls"
Content-Transfer-Encoding: base64
Content-Type: application/vnd.ms-excel;
	name="FILE.xls"

0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAOwADAP7/CQAGAAAAAAAAAAAAAAAB
:::



Comment 11

11 years ago
I generated this message mostly by hand, and I'm pretty sure it's correct, but Thunderbird 2.0 doesn't render the text/plain part when View -> Message Body As -> Plain Text is selected. It just shows a blank page. If I remove the multipart/related section and replace it with straight HTML it works fine obviously, as this is the common option.


From: "Matthew Allen" <fret@memecode.com>
Subject: Martin's 3rd Birthday Party Invite
MIME-Version: 1.0
Content-Type: multipart/alternative;
	Boundary="----=_NextPart_144E783A.00001608"

------=_NextPart_144E783A.00001608
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset="us-ascii"

Hi guys,

Attached is the official invite to Marty's 3rd bday picnic BBQ, love to see 
you there... :)

Much love,
Mags (+the rest of the Mallens)
xx

------=_NextPart_144E783A.00001608
Content-Type: multipart/related;
	Boundary="----=_NextPart_144E783A.html"

------=_NextPart_144E783A.html
Content-Transfer-Encoding: 7bit
Content-Type: text/html

<html>
<body>
<img src="cid:Invite.jpg"/>
</body>
</html>

------=_NextPart_144E783A.html
Content-Type: image/jpeg; name="Invite.jpg"
Content-Transfer-Encoding: base64
Content-Id: Invite.jpg

/9j/4AAQSkZJRgABAgAAZABkAAD/7AARRHVja3kAAQAEAAAAHgAA/+4ADkFkb2JlAGTAAAAAAf/b
AIQAEAsLCwwLEAwMEBcPDQ8XGxQQEBQbHxcXFxcXHx4XGhoaGhceHiMlJyUjHi8vMzMvL0BAQEBA
[snipped]
H+Inhtx24P8AuYP8RQHKi6vDbjtwf9zB/iJ4bcduD/uYP8RUHovJP8K7+0z3OXqF5zyhbyQR3QeW
HM5lN3IyTYHbd251F6NQqCIiAIiIAiIgCIiAIiIAiIgCIiAIiIAiIgP/2Q==

------=_NextPart_144E783A.html--

------=_NextPart_144E783A.00001608--
QA Contact: front-end

Comment 12

11 years ago
Hi,

it appears to be connected to IMAP. We keep getting this problem with several messages. Though, saving the messages as an .eml file and then opening the .eml files with Thunderbird always shows the message text as expected!
(running TB 2.0.0.0 on Windows XP)

Injecting the saved .eml back into the IMAP server shows the same behaviour, so the message is not modified at saving, thus it must be connected to IMAP directly (methinks :-) .
I tried to disable mail.imap.mime_parts_on_demand, but no difference.

All of the affected messages have an html part, and one image in the html part (mostly in the signature, aaarrgh!). Even when switching to plain-text view, the message text is not displayed! (Enabling display-attachments-inline is a workaraound, but not useful.)

Though, f.i. MS Outlook displays these messages correctly.

We would be very pleased if this could be fixed. This bug is imho very bad,
since recipients really *miss* information: As some people or platforms keep sending emails containing just an attachment without any text, the error is *not* obvious to the recipient - so they just open the attachment and discard the message text (this already happend, in business use, quite embarassing).

I will post a truncated sample message.

Kind regards,
Philipp

Comment 13

11 years ago
Created attachment 264882 [details]
Truncated sample message

I tried to truncate what is not necessary - also the header is not complete.
The original message showed the bug, 100% reproduceable.

Updated

11 years ago
Attachment #264882 - Attachment description: Truncated sample message (Philipp) → Truncated sample message

Comment 14

11 years ago
I am seeing this bug occasionally.  I am running version 1.5.0.10 with an IMAP server.  Most times, I can recover by deleting the e-mail, going into a web-mail program and marking the message "undeleted" and "new", then going back to Thunderbird for "Get Mail", but this does not work every time.

Comment 15

11 years ago
This seems to be happening more often since 2.0.0.0, HTML emails seems to be cut at random points, I've seen the same email stop a different places when thunderbird is closed and reopened.
Also when using reply, the compose pane can also stay blank and become non responsive.

Comment 16

11 years ago
Yes it seems to be more frequent in 2.0.0.0.
But, in the cases I noticed, the message body always became visible, as soon as I pressed the reply button.

What I do notice frequently is that MIME (de-)encapsulation seems to be confused, when I try to open an attached eml file in a message (often found in error-reports sent from various MTAs): It is often not possible to open the attached eml, or (if opening the eml works) the menu option to display its source is greyed out.

My *suspicion* is that there is some problem in thunderbirds MIME decoding, which prevents thunderbird from finding attached inline images - and thus thunderbird stumbles when trying to display the message body.
(Perhaps this is not a bug, rather a kind of stolidity regarding encapsulation mistakes in the received messages. Though, no difference for the user.)

Comment 17

10 years ago
running Thunderbird 2.0.0.16
Yesterday I lost (silently & all of a sudden) all the body of my Inbox e-mails from 1pm yesterday (several thousand) back to when I installed Thunderbird last February.   Subfolders are ok.  The Subject Headings were all there, but there was no body to the e-mails.   New e-mails (after 1pm yesterday) are ok.  On compacting the folders all the headings were lost and I only have the new e-mails left.
The same problem occurred last February when I was running Netscape 7.0 Mail (which caused me to migrate to Thunderbird) when we also lost all our old Inbox e-mails (about a gigabyte of e-mails).
This appears to be a long-standing bug in Mozilla/Thunderbird and is quite devastating.
My workaround is to filter all incoming e-mails from Inbox to a subfolder.   Hopefully this works.

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Keywords: testcase
Using latest 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090924 Lightning/1.0pre Shredder/3.0pre ID:20090924031806

opening attached testcase "Message Body example, which can't be displayed" I have a crash (Id: 478b895e-d82c-40c5-bf9b-6ebec2090925)

Wayne any idea?
(In reply to comment #18)
> Using latest 
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090924
> Lightning/1.0pre Shredder/3.0pre ID:20090924031806
> 
> opening attached testcase "Message Body example, which can't be displayed" I
> have a crash (Id: 478b895e-d82c-40c5-bf9b-6ebec2090925)

Can't find the crash ? weird.

Comment 21

9 years ago
(In reply to comment #20)
> It is here
> http://crash-stats.mozilla.com/report/index/478b895e-d82c-40c5-bf9b-6ebec2090925

cool. so we have a testcase for bug 518686
Severity: normal → major
Component: Mail Window Front End → MIME
Keywords: intl
Product: Thunderbird → MailNews Core
QA Contact: front-end → mime

Updated

9 years ago
Blocks: 518686
Status: UNCONFIRMED → NEW
Ever confirmed: true
Cool indeed, but there doesn't seem to be a dependency relationship between the two bugs.
No longer blocks: 518686

Comment 23

9 years ago
The issue as I saw it seems to be resolved with Thunderbird 3!
Though I am not sure whether we are all talking about the exact same bug...

Comment 24

9 years ago
Thanks Philippp. Two issues, which testcase was used, and what dated+version of thunderbird 3 did you use (help|about)?  And, is it same testcase used in comment 18?  (see bug 518686 comment 4)

Comment 25

9 years ago
Well (quite blatantly trivial) I just openend two of those problematic messages from our production environment here after installing TB 3.0, and they now show correctly (while they still show as empty with TB 2.0.23).

So my test is not against the filed testcase - I probably would not close this without at least a second opinion...

Comment 26

4 years ago
Created attachment 8374656 [details]
message without text

This email does not show up any text in the Thunderbird main window, although the email source confirms that the text is there.

Comment 27

4 years ago
Comment on attachment 8374656 [details]
message without text

This problem appears at least on my Thunderbird 24.3.0, ENG, Windows 7 64 bits.
The source of the last message is this:

multipart/related
+ multipart/alternative
++ text/html [This part has gobs and gobs and gobs of data]
++ text/plain [this is empty]
+ application/octet-stream
+ image/jpeg
+ image/jpeg

Whoever coded the program that generated this message is an idiot and needs to learn how MIME works, because there's at least two glaring issues. It appears to be that the author tested it only with Outlook, which displays the text (because it doesn't process MIME correctly), and therefore assumed it must work everywhere.

Although this is also more fuel for my opinion that we should stop caring about the order of parts in a multipart/alternative and instead care about the Content-Type. Unfortunately, I don't think it's feasible to make these kinds of invasive changes to our current libmime infrastructure.

Comment 29

4 years ago
Dear Joshua,
I agree with you, but the problem is that there may be a lot of idiots that use Outlook to send messages and we (with Thunderbird) are not able to read them. So, at the end of the story, for most of the people it looks the idiot is me, who is not able to read the messages that everybody else can read :-(

Comment 30

4 years ago
I hope there are still people here maintaining TB.

Failure to display message bodies in the Body pane seems to happen in TB 24.6.0 in Windows 8, but only after I experimented with various TB display options. The normal window title is also missing. This has nothing to do with formatting on either Outlook or TB, since clicking on a folder in the folder pane, then any message listed in the Messages pane (with column headings) highlights the folder and message, but fails to show the body in the Body pane. To see the body, one must now double-click the message line in the Messages pane.

I think the problem is that something I did in my TB experimenting made the auto-download or auto-display feature stop working, regardless of message content. I was unable to retrace my steps enough to fix the problem.

I emphasize that this is new behavior; TB worked correctly for me for several months prior to my experimentation today.

Is this the same bug or do we need a new bug report?

Comment 31

4 years ago
Problem cause is experimenting with different layouts (Menu > View > Layout > ...) Problem is empty message pane until TB is closed and reopened. Hope this helps someone.

Comment 32

4 years ago
Created attachment 8459209 [details]
TEMP_TB_test_email_source.txt

Comment 33

4 years ago
I have been using Thunderbird (TB) since Dec 16, 2008 (ver 2.0.0.18) on Windows Vista 32 bit on a Lenovo y710 laptop, and have never seen missing body text on that configuration.  On May 5, 2014 I retired the Lenovo laptop with a fairly current version of TB (don't remember which but it was prior to ver 24.5.0). Multiple POP accounts had incoming emails being scanned with Norton antivirus. 

The first time I noticed the missing body text problem was on July 8, 2014 on TB ver 24.5.0 on an ASUS x750 laptop running Windows 8.1 64 bit.  This POP account (account4 below) had incoming emails being scanned with Iolo System Shield antivirus. I received an email where the body text was truncated in the middle of the first paragraph.  It was sent from a corporation using Microsoft Outlook/Exchange and as far as I know only included text (no images were attached or embedded).  When looking at the message source (View->MessageSource), the message body text was truncated in the same place.  The source contained only text, I saw no HTML part.  Not sure if this was an example of this bug or not since the message source was also truncated.  I know for a fact that the complete message text was sent because another recipient copied on the email received the complete message text, and I was able to see the complete message text when they forwarded it to me later. 

The second time that I noticed the missing body text problem was on July 18, 2014 using TB ver 24.5.0 on the same ASUS x750 laptop running Windows 8.1 using the same POP account (account4 below).  I received numerous emails from multiple people where the message body displayed completely empty (nothing visible in the body area when viewing the message).  I have the message pane turned off, so to view the message I have to double click on the message in the message list.  On this day, with all the messages, even though the message body was empty when viewing the message, the message source (View->MessageSource) showed the complete message body.  Email one sent to me directly, contained text and 2 images, and the sender's mail system specifics are unknown.  Email one was subsequently forwarded to me by 2 other people and no body text displayed (body would have included original email and added text), but all text & images were in the message source.  One of the sender's mail system specifics are unknown, and the other uses Mac mail.  The message source for email one contained both text and HTML.  A few minutes later the Mac mail user forwarded email one again, but without images and its message text displayed fine and matched the message source. 
About an hour later, I composed email two using TB which contained text and 3 screen-shot images (created with Windows snipping tool) pasted inline into the body.  I sent it out with a blind copy to myself.  When I displayed my blind copy of the message, the body was completely empty, but the message source contained all the text and images.  
After this I did subsequent testing and determined that if even one of the images was present in the outgoing mail, the blind copy to myself would display an empty body, but the message source contained all text and image(s).  I even tried sending the email with images to another POP account (account2 below) that I have on this TB client, and in this case both the other POP account and the blind copy to myself displayed an empty body, but the message source contained all text and image. I upgraded TB to ver 24.6.0 in between some of the above tests and saw no change in behavior.

On July 19, 2014 using TB ver 24.6.0 on the same ASUS x750 laptop running Windows 8.1 64 bit using the same POP account (account4 below), I ran a subsequent test with no change in behavior. I composed email 3 with text only and sent it to a second POP account (account2 below) with a blind copy to myself and a copy to a POP hotmail account (account6 below).  The body text was displayed correctly when the message was viewed, and the message source contained all the text. I then composed email 4 with text and an image (created via Windows snip tool) copied inline and sent it to a second POP account (account2 below) with a blind copy to myself and a copy to a POP hotmail account (account6 below).  The body text was completely empty when the message was viewed in all but the hotmail account6, and the message source contained all the text and the image in all accounts. Email 4 in the sent folder displayed text and image correctly as one would expect.  The message source for email 4 in the above tests showed both text & HTML, and the message source for email 3 only showed text (no HTML--not sure why, since the only difference was copying the image inline). 
It is worth noting that in all the tests that I conducted on July 18 and 19, when I go to the sent folder and view the message, the body text and images display completely as you would expect.  Over these two days, I have used about 3 different images in the various tests, so I doubt that this behavior is being caused by image content.

On July 19, on the same configuration as above, I ran a test sending email 5 from an IMAP account (account10 below).  I composed email 5 with text and an image (created via Windows snip tool) copied inline and sent it to a second POP account (account2 below) with a blind copy to myself.  The body text in the blind copy was completely visible as you would expect, and the message source had text and image in text & HTML form. The sent folder message when viewed also had the body text completely visible as you would expect, and the message source had text and image in text & HTML form.  When I went to the POP account (account2 below), and viewed the message, the body was completely empty, and the message source had the text and image there in text & HTML form. 

On July 19, on the same configuration as above, I ran a test sending email 6 from the same POP account (account4 below), but the image was attached rather than copied inline.  I composed email 6 with text and an image (created via Windows snip tool) which was attached (Attach->File) and sent it to a second POP account (account2 below) with a blind copy to myself and a copy to a POP hotmail account (account6 below).  When viewed, both the sent folder and the blind copy displayed text and image withing the body of the message.  Both had text and image in the message source, but no HTML.  When I went to the second POP account (account2 below) and viewed the message, the body displayed text and image as you'd expect and the message source contained the text and image, but no HTML. When I went to the POP hotmail account (account6 below) and viewed the message, the body displayed text and image as you'd expect and the message source contained the text and image, but no HTML. 

On July 19th at the time of the above tests my Help->TroubleshootingInformation shows the following (some of the email domains have been xxx'd out for privacy): 
  Application Basics
    Name: Thunderbird
    Version: 24.6.0
    User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
    Profile Folder: Show Folder
              (Local drive)
    Application Build ID: 20140610001341
    Enabled Plugins: about:plugins
    Build Configuration: about:buildconfig
    Crash Reports: about:crashes
    Memory Use: about:memory

  Mail and News Accounts
    account1:
      INCOMING: account1, , (none) Local Folders, plain, passwordCleartext
    account2:
      INCOMING: account2, , (pop3) mail.ca.xxxx.net:110, plain, passwordCleartext
      OUTGOING: smtp2.xxxx.com:2225, plain, passwordCleartext, true
    account3:
      INCOMING: account3, , (nntp) news.xxxx.net:119, plain, passwordCleartext
      OUTGOING: smtp.ca.xxxx.net:25, plain, none, true
    account4:
      INCOMING: account4, , (pop3) mail.xxxx.com:110, plain, passwordCleartext
      OUTGOING: smtp2.xxxx.com:2225, plain, passwordCleartext, true
    account5:
      INCOMING: account5, , (pop3) pop3.live.com:995, SSL, passwordCleartext
      OUTGOING: smtp.live.com:587, alwaysSTARTTLS, passwordCleartext, true
    account6:
      INCOMING: account6, , (pop3) pop3.live.com:995, SSL, passwordCleartext
      OUTGOING: smtp.live.com:587, alwaysSTARTTLS, passwordCleartext, true
    account8:
      INCOMING: account8, , (pop3) mail.yyyy.com:110, plain, passwordCleartext
      OUTGOING: smtp2.xxxx.com:2225, plain, passwordCleartext, true
    account10:
      INCOMING: account10, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.gmail.com:465, SSL, passwordCleartext, true

  Extensions
    Lightning, 2.6.6, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
    WebMail, 1.5.1, true, {3c8e8390-2cf6-11d9-9669-0800200c9a66}
    WebMail - Hotmail, 1.3.10, true, {a6a33690-2c6a-11d9-9669-0800200c9a66}

  Important Modified Preferences
    Name: Value
      accessibility.typeaheadfind.flashBar: 0
      browser.cache.disk.capacity: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      browser.cache.disk.smart_size_cached_value: 358400
      extensions.lastAppVersion: 24.6.0
      font.internaluseonly.changed: false
      font.minimum-size.x-western: 20
      font.name.monospace.el: Consolas
      font.name.monospace.tr: Consolas
      font.name.monospace.x-baltic: Consolas
      font.name.monospace.x-central-euro: Consolas
      font.name.monospace.x-cyrillic: Consolas
      font.name.monospace.x-unicode: Consolas
      font.name.monospace.x-western: Consolas
      font.name.sans-serif.el: Calibri
      font.name.sans-serif.tr: Calibri
      font.name.sans-serif.x-baltic: Calibri
      font.name.sans-serif.x-central-euro: Calibri
      font.name.sans-serif.x-cyrillic: Calibri
      font.name.sans-serif.x-unicode: Calibri
      font.name.sans-serif.x-western: Courier
      font.name.serif.el: Cambria
      font.name.serif.tr: Cambria
      font.name.serif.x-baltic: Cambria
      font.name.serif.x-central-euro: Cambria
      font.name.serif.x-cyrillic: Cambria
      font.name.serif.x-unicode: Cambria
      font.name.serif.x-western: Cambria
      font.size.fixed.el: 14
      font.size.fixed.tr: 14
      font.size.fixed.x-baltic: 14
      font.size.fixed.x-central-euro: 14
      font.size.fixed.x-cyrillic: 14
      font.size.fixed.x-unicode: 14
      font.size.fixed.x-western: 20
      font.size.variable.el: 17
      font.size.variable.tr: 17
      font.size.variable.x-baltic: 17
      font.size.variable.x-central-euro: 17
      font.size.variable.x-cyrillic: 17
      font.size.variable.x-unicode: 17
      font.size.variable.x-western: 20
      mail.openMessageBehavior.version: 1
      mail.winsearch.enable: true
      mail.winsearch.firstRunDone: true
      mail.winsearch.global_reindex_time: 1271461206
      mailnews.database.global.datastore.id: 203339fc-5c13-4105-8051-25a0bebd363
      network.cookie.prefsMigrated: true
      places.database.lastMaintenance: 1405446349
      places.history.expiration.transient_current_max_pages: 104858
      plugin.importedState: true
      plugins.update.notifyUser: true
      print.print_printer: Brother HL-2170W series
      print.printer_Brother_HL-2170W_series.print_bgcolor: false
      print.printer_Brother_HL-2170W_series.print_bgimages: false
      print.printer_Brother_HL-2170W_series.print_command:
      print.printer_Brother_HL-2170W_series.print_downloadfonts: false
      print.printer_Brother_HL-2170W_series.print_edge_bottom: 0
      print.printer_Brother_HL-2170W_series.print_edge_left: 0
      print.printer_Brother_HL-2170W_series.print_edge_right: 0
      print.printer_Brother_HL-2170W_series.print_edge_top: 0
      print.printer_Brother_HL-2170W_series.print_evenpages: true
      print.printer_Brother_HL-2170W_series.print_footercenter:
      print.printer_Brother_HL-2170W_series.print_footerleft: &PT
      print.printer_Brother_HL-2170W_series.print_footerright: &D
      print.printer_Brother_HL-2170W_series.print_headercenter:
      print.printer_Brother_HL-2170W_series.print_headerleft: &T
      print.printer_Brother_HL-2170W_series.print_headerright: &U
      print.printer_Brother_HL-2170W_series.print_in_color: true
      print.printer_Brother_HL-2170W_series.print_margin_bottom: 0.5
      print.printer_Brother_HL-2170W_series.print_margin_left: 0.5
      print.printer_Brother_HL-2170W_series.print_margin_right: 0.5
      print.printer_Brother_HL-2170W_series.print_margin_top: 0.5
      print.printer_Brother_HL-2170W_series.print_oddpages: true
      print.printer_Brother_HL-2170W_series.print_orientation: 0
      print.printer_Brother_HL-2170W_series.print_pagedelay: 500
      print.printer_Brother_HL-2170W_series.print_paper_data: 1
      print.printer_Brother_HL-2170W_series.print_paper_height: 11.00
      print.printer_Brother_HL-2170W_series.print_paper_size_type: 0
      print.printer_Brother_HL-2170W_series.print_paper_size_unit: 0
      print.printer_Brother_HL-2170W_series.print_paper_width: 8.50
      print.printer_Brother_HL-2170W_series.print_reversed: false
      print.printer_Brother_HL-2170W_series.print_scaling: 0.60
      print.printer_Brother_HL-2170W_series.print_shrink_to_fit: false
      print.printer_Brother_HL-2170W_series.print_to_file: false
      print.printer_Brother_HL-2170W_series.print_unwriteable_margin_bottom: 0
      print.printer_Brother_HL-2170W_series.print_unwriteable_margin_left: 0
      print.printer_Brother_HL-2170W_series.print_unwriteable_margin_right: 0
      print.printer_Brother_HL-2170W_series.print_unwriteable_margin_top: 0
      security.disable_button.openCertManager: false

  Graphics
      Adapter Description: Intel(R) HD Graphics 4600
      Vendor ID: 0x8086
      Device ID: 0x0416
      Adapter RAM: Unknown
      Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
      Driver Version: 10.18.10.3308
      Driver Date: 9-16-2013
      Direct2D Enabled: false
      DirectWrite Enabled: false (6.3.9600.17111)
      ClearType Parameters: ClearType parameters not found
      WebGL Renderer: false
      GPU Accelerated Windows: 0
      AzureCanvasBackend: skia
      AzureFallbackCanvasBackend: cairo
      AzureContentBackend: none

  JavaScript
  Incremental GC: 1
  Accessibility
    Activated: 0
    Prevent Accessibility: 0

  Library Versions
      Expected minimum version
      Version in use
      NSPR
      4.10.2
      4.10.2
      NSS
      3.15.4 Basic ECC
      3.15.4 Basic ECC
      NSS Util
      3.15.4
      3.15.4
      NSS SSL
      3.15.4 Basic ECC
      3.15.4 Basic ECC
      NSS S/MIME
      3.15.4 Basic ECC
      3.15.4 Basic ECC

Looks like I have a repeatable test case under my current configuration.  Looks like an image inline in the body of the mail causes a problem when viewed from a POP account--IMAP displays normally.  Body text with an attached image displays normally in a POP account.  Can someone from TB development let me know if I can provide any further diagnostic info before my configuration changes.  
I added the message source for one of my emails in the test above - sorry I'm a newbie to this and it may have gotten posted before this comment.

Comment 34

4 years ago
Bruce and I are clearly encountering different bugs with a similar symptom. In his case, he is able to offer a test file to replicate the symptom. In my case, I am able to offer a user input sequence that replicates the symptom.

For those interested in this symptom (an empty message pane in the standard view), please note there are many bug reports here of empty text pane contents. They are not necessarily all describing the same bug. And some of the bug reports, like this one, are mixing two or more bugs together.

It might be useful for someone to analyze all the bug reports for this one symptom and sort out all the comments into a unique and exclusive set of bug reports that don't overlap. This would make fixing the bugs easier for those who have the time to delve into TB source files.

Comment 35

4 years ago
(In reply to Joshua Cranmer [:jcranmer] from comment #28)
> Although this is also more fuel for my opinion that we should stop caring
> about the order of parts in a multipart/alternative and instead care about
> the Content-Type. Unfortunately, I don't think it's feasible to make these
> kinds of invasive changes to our current libmime infrastructure.

which jsmime bug# gets us there?
Flags: needinfo?(Pidgeot18)
(In reply to Wayne Mery (:wsmwk) from comment #35)
> (In reply to Joshua Cranmer [:jcranmer] from comment #28)
> > Although this is also more fuel for my opinion that we should stop caring
> > about the order of parts in a multipart/alternative and instead care about
> > the Content-Type. Unfortunately, I don't think it's feasible to make these
> > kinds of invasive changes to our current libmime infrastructure.
> 
> which jsmime bug# gets us there?

I don't have any bug on file for that portion yet; it's still only in my mental planning and design stages.
Flags: needinfo?(Pidgeot18)

Comment 37

3 years ago
This is a follow up to my posting above on: 2014-07-19 13:13:39 PDT.

First, thanks to David for his comments.  After reading them, I spent a couple hours searching TB's bug database in August, with the intent of categorizing the bugs related to my symptoms and maybe taking a first step toward doing what he suggested in this comment: "sort out all the comments into a unique and exclusive set of bug reports that don't overlap".  Unfortunately I became overwhelmed and gave up (also busy with other work), due to my unfamiliarity with the inner workings of TB as well as my unfamiliarity with the inner structure of email messages. My apologies to all for my lack of follow through. 

Secondly, after much more thought, several more occurrences of lost body text, and some more testing, I think I have located the source of my problem.  I am currently using Iolo System Shield 4 as an anti-virus solution.  There are two parts to Iolo's AV: real-time protection and email protection.  When I turn off the email protection, my body text and embedded images are visible.  Turning the real-time protection on or off does not seem to affect the email behavior.  I think the bottom line to my problem, is that the Iolo AV is erroneously removing text & images from my email messages as they are downloaded from the server to the client. I will run for a few weeks without email AV scanning to see what happens, but I feel pretty certain that this is not a TB issue. 

Thirdly, thanks to all the people who have made Thunderbird what it is today. All your hard work is appreciated!

Comment 38

3 years ago
Bruce, Don't worry about being overwhelmed. I'm sure someday all of TB's bugs (I've found others) will be found and fixed. Thank you for your wonderful story of finding what caused your missing message bodies.

The bugs I've encountered are definitely the exception; TB is a marvelous product, and I've learned to customize it to meet my needs very nicely.

I, too, appreciate everyone's hard work to give TB continuing life in a world filled with poor alternatives to TB.
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.

Updated

8 months ago
Attachment #223851 - Attachment is obsolete: true

Comment 40

8 months ago
Attachment 220918 [details] displays fine.
Attachment 264882 [details] displays fine.
Attachment 8374656 [details] displays fine, as per comment #23 the plain text part is empty.
Attachment 8459209 [details] displays fine.
Tested in TB 58 Daily, but should be the same in TB 52 ESR since to my knowledge all MIME improvement we've made were uplifted.

I see no need for action here. If you have problems with another message, please file another bug, this bug here is not actionable.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.