outerHTML property in MsHtml.IHtmlElement is not implemented

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
15 years ago
7 years ago

People

(Reporter: atremon, Assigned: adamlock)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

put_outerHTML and get_outerHTML are not implemented in CIEHtmlElement class

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 139970 [details] [diff] [review]
put_outerHTML and get_outerHTML implementation

Comment 2

15 years ago
dupe of bug 92264?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
bug 92264 is about the mozilla dom.
This is about the Mozilla Control which is intended to replace the IE activeX.

(Reporter)

Comment 4

15 years ago
Created attachment 139972 [details] [diff] [review]
previous attachment was not a diff
Attachment #139970 - Attachment is obsolete: true
(Assignee)

Comment 5

15 years ago
Comment on attachment 139972 [details] [diff] [review]
previous attachment was not a diff

r=adamlock

Looks great to me
Attachment #139972 - Flags: review+
(Reporter)

Updated

15 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Updated

15 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 139972 [details] [diff] [review]
previous attachment was not a diff

 HRESULT STDMETHODCALLTYPE CIEHtmlElement::put_outerHTML(BSTR v)
 {
-    return E_NOTIMPL;
+	nsresult rv;
+	nsCOMPtr<nsIDOMDocument> domDoc;
...

This new code uses tabs for indentation, don't. Follow what's used in the rest
of the file.

 HRESULT STDMETHODCALLTYPE CIEHtmlElement::get_outerHTML(BSTR __RPC_FAR *p)
 {
...
+    }
+
+    *p = NULL;
+
+	nsresult rv;
+	nsAutoString outerHTML;

Mixed indentation, stick with spaces, don't use tabs.

sr=jst with the indentation fixed.
Attachment #139972 - Flags: superreview?(jst) → superreview+
(Reporter)

Comment 7

15 years ago
Created attachment 140399 [details] [diff] [review]
Indentation fixed
(Assignee)

Comment 8

15 years ago
Fix is checked in, thanks Alexandre!
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.