Proxy: Cannot get past initial page when accessing internal IIS served webpages that are exempted from proxy server

VERIFIED DUPLICATE of bug 91587

Status

()

--
major
VERIFIED DUPLICATE of bug 91587
15 years ago
15 years ago

People

(Reporter: pspuhler, Assigned: darin.moz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

I have installed mozilla 1.6 on both debian linux and win2k. I have problems
accessing internal webpages that run on IIS and livelink using NTLM. I remember
these working ok with mozilla 1.4 on win2k. In each case i can get to the
starting page but when i click on a link i get referred to the proxy server
SQUID which returns an error for internal sites. I specifically exclude interal
sites from the proxy. Accessing internal apache websites works without a
problem. Also accessing internal IIS pages not using authentication also works
fine. This problem occurs on linux and win2k. Mozilla appears to forget to
ignore the proxy server when accessing an internal website after using NTLM
authentication.

Reproducible: Always
Steps to Reproduce:
1.Log into a website running IIS and using NTLM
2.Click on link
3.Get referred to proxied version of website which produces error from proxy server

Actual Results:  
Proxy server error for trying to access and internal website

Expected Results:  
Browser should have not attempted to access proxy server for an internal website
Assignee: general → darin
Component: Browser-General → Networking: HTTP
QA Contact: general → httpqa

Comment 1

15 years ago
Can you describe your proxy config, or are you getting a 305 redirect?
Summary: Cannot get past initial page when accessing internal IIS served webpages that are exempted from proxy server → Proxy: Cannot get past initial page when accessing internal IIS served webpages that are exempted from proxy server
(Assignee)

Comment 2

15 years ago
reporter: can you please generate a HTTP log using the steps given here:

http://www.mozilla.org/projects/netlib/http/http-debugging.html

please generate the log file and attach it to this bug or email it directly to
me.  thanks!
(Assignee)

Comment 3

15 years ago
(In reply to comment #1)
> Can you describe your proxy config, or are you getting a 305 redirect?

the log file from the reporter does not include any 305 responses.  anyways,
mozilla ignores 305 for security reasons.
(Assignee)

Comment 4

15 years ago
Inspecting the log file, I see a request like the following:

  GET http://aerokm/livelink/llisapi.dll?... HTTP/1.1

This is the first proxy request.  Up until this point, all requests have been
for aerokm.ball.com, so I suspect that the no_proxies_on preference does not
include "aerokm" in the list.  It probably includes "ball.com" only?  Is that
correct?  If so, then I suspect this is a duplicate of a well-known problem in
Mozilla (namely that we do not resolve the hostname before comparing it against
the no_proxies_on list).

reporter: can you please confirm that this is what's going on?  thx!
Whiteboard: [DUPEME]
(Assignee)

Comment 5

15 years ago
Peter wrote:
> no proxy for 
> .ball.com
> http ssl and ftp is 
> webcache.ball.com port 3128

so, indeed this bug is a duplicate... searching for the duplicate bug report now.
(Assignee)

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 91587 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
V/dupe.

Not sure why this worked in 1.4, perhaps the page changed?
Status: RESOLVED → VERIFIED
QA Contact: httpqa → benc
Whiteboard: [DUPEME]
You need to log in before you can comment on or make changes to this bug.