Standardized extension installation place handling desperately needed

VERIFIED DUPLICATE of bug 226680

Status

()

Firefox
Installer
VERIFIED DUPLICATE of bug 226680
15 years ago
12 years ago

People

(Reporter: Marcin Kasperski, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Firebird extensions can be installed either in firebird directory or in user
profile directory. And there is a total mess with respect to selecting where to
install:
- some extensions display dialog box, requiring OK for profile directory and
Cancel for firebird directory
- some extensions display similar dialog box but OK is required for firebird
directory and Cancel for profile dir
- in both cases above the actual question is differently phrased and use
different terminology ('application directory', 'Firebird directory',
'installation directory')
- some extensions use more complicated ways of asking (for instance FirebirdHelp
displays intro dialog box, then Ok/Cancel question whether to install into
firebird dir, then Ok/Cancel question whether to intall into profile dir)
- some extensions does not ask this question at all (usually trying to install
into Firebird dir)

This looks terrible.

Main recommendation: whether this question is asked and how does it look if so
should be somehow defined once and forever in one single place. Whatever
extension I install, I should be given the same dialog box with the same buttons
of the same meaning.

Additional recommendations:

- maybe Firebird could always install extensions into profile directory and the
ability of installing within firebird installation dir could be removed. After
all, everybody wants his extensions to persist after firebird upgrade. And no
dialog box is then needed.

- otherwise, I'd prefer setting preferred extensions place once in configuration
instead of being asked this question each time I install the extension


- finally, if there is a dialog box displayed while extension is being
installed, it should probably look so:

     Choose installation place

     Install this extension:
     (*) in my profile directory (extension will remain after firebird upgrade)
     ( ) in the firebird installation dir (extension will be available to all
users on the machine but will disappear after upgrade)
          [Proceed]

     or

     Choose installation directory

      < some standard explanation >

           [ Install in Profile ]  [ Install System Wide ]

- and if permissions on the mozilla installation dir are restricted (typical on
Unix/Linux, possible on Windows) and the current user has no rights to write
firebird directory, extensions should install in the profile directory without
question


Reproducible: Always
Steps to Reproduce:

Comment 1

15 years ago
Setting a global preference for where to install extensions (profile/main
Mozilla Firebird directory) is covered by bug 226680.  Changing the installation
UI so that it isn't confusing is covered by bug 214260.  When 0.8 is released,
it should have bug 214260 fixed (somehow, I don't know exactly how much of your
suggestions it covers).  Bug 226680 will *probably* be fixed sometime before 0.9.

In any case, this is being dealt with in other bugs.

*** This bug has been marked as a duplicate of 226680 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.