Last Comment Bug 232506 - Accept: Add XUL support
: Accept: Add XUL support
Status: VERIFIED WONTFIX
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: All All
: -- minor with 2 votes (vote)
: ---
Assigned To: Darin Fisher
:
Mentors:
http://arcanes.fr.eu.org/~pierre/bugs...
: 241427 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-28 23:51 PST by Nowhere man
Modified: 2004-04-26 05:32 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Nowhere man 2004-01-28 23:51:30 PST
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Debian/1.5-3

When a web server supporting content negotiation provides an (X)HTML page and an
equivalent XUL document, as XUL is far more convenient for it's purpose, user
interface, than HTML is, Mozilla should use the XUL document.

So application/vnd.mozilla.xul+xml should be included in the Accept header.

Reproducible: Always
Steps to Reproduce:
1. Go to a URL providing transparent content negotiation with a XUL and an HTML
alternatives
Actual Results:  
The HTML one is received from server

Expected Results:  
The XUL one should be received from server
Comment 1 Gervase Markham [:gerv] 2004-01-29 14:52:25 PST
The reason we didn't do this in the past is that there are so many
XUL-supporting browsers out there (Netscape 7, all previous versions of Mozilla
and Mozilla Firebird, Beonex etc.) that if we put it in and people started using
it, a lot of browsers would get unfairly excluded.

That argument gets more true the longer we don't have it in there.

Gerv
Comment 2 Christian :Biesinger (don't email me, ping me on IRC) 2004-04-23 05:39:39 PDT
*** Bug 241427 has been marked as a duplicate of this bug. ***
Comment 3 Xavier MOUTON-DUBOSC 2004-04-23 05:49:41 PDT
Well, longer you will waiting for correcting this, harder it will be possible.
And when Microsoft will start promoting XAML, Moz will be out.

For creating virtual listing, web applications,.... we should have possibility
onto the server-side to know if we can switch in xul with another method than
guessing, or any ugly manners. Just think about websites using flash...

After that, rewriting by example virtual listing extension for apache will be
faster, more user-friendly and more convincing for moz.
Comment 4 Brendan Eich [:brendan] 2004-04-23 19:53:23 PDT
XAML has nothing to do with this. Accept: as content negotiation header, with
exhaustive list of MIME types supported, is a complete failure.  We should not
bloat our Accept: headers to include XUL's vendor MIME type.

/be
Comment 5 benc 2004-04-24 23:18:06 PDT
V/WONTFIX
Comment 6 Xavier MOUTON-DUBOSC 2004-04-26 05:32:32 PDT
And if, in a near future, another rendering motor like KHTML or Opera, will
accept XUL ? How to be sure ? guessing via user-agent or by a javascript
response is, imho, too much dirty method.

or creating a shorter type mime for .xul ?

Note You need to log in before you can comment on or make changes to this bug.