Closed Bug 232537 Opened 18 years ago Closed 18 years ago

Tables with bdcolor="Transparent" render with a bight blue (#0000e0) background.

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 227072

People

(Reporter: jesse.houwing, Assigned: dbaron)

Details

Attachments

(1 file)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040128 Firebird/0.7+

I know that Transparent is no valid backgroundcolor, but ASP.net seems to
generate this code for tables and other constructs if a browser isn't mentioned
in the browsercap.ini. This is how I came across this error.

So if your table has bgcolor="Transparent" in it the table is rendered with a
brigth blue backgroudn while the color code should be ignored altogether and
default to it's inherited bgcolor.

Reproducible: Always
Steps to Reproduce:
Attached file TestCase
Testcase added.
don't think this is html parser... trying style system

let me note that the table in the testcase should not necessarily be white, but
be the default background color.
Assignee: parser → dbaron
Component: HTML: Parser → Style System (CSS)
QA Contact: ian
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 227072 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.